SFM: Critical Error After Applying U.S. Service Pack 1 (106555)



The information in this article applies to:

  • Microsoft Windows NT Server 3.1
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Advanced Server 3.1

This article was previously published under Q106555

SYMPTOMS

If you try to install Services for Macintosh after installing U.S. Service Pack 1 for Windows NT and Windows NT Advanced Server version 3.1, the following error message may appear:
A critical error has occurred.

The INF OEMNXPSM is missing the referenced file description section [Files - SFM].

Check for missing lines.

CAUSE

The file OEMNXPSM.INF is missing from the SYSTEM32 directory. Services for Macintosh is not able to install without this file.

WORKAROUND

To work around this problem, expand the OEMNXPSM.IN_ file from the original disks or CD-ROM using the following command

expand <source>:\oemnxpsm.in_ <winnt>\SYSTEM32\oemnxpsm.inf

where <source> is the media you originally installed Windows NT from (including the appropriate platform directory, I386 or MIPS) and <winnt> is the location of your Windows NT system files.

Services for Macintosh will now install successfully.

NOTE: After installing Services for Macintosh, reapply U.S. Service Pack 1 to update the Services for Macintosh files.

STATUS

Microsoft has confirmed this to be a problem in Windows NT and Windows NT Advanced Server version 3.1. This problem was corrected in the latest U.S. Service Pack for Windows NT and Windows NT Advanced Server version 3.1. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K


Modification Type:MajorLast Reviewed:11/20/2003
Keywords:kbsetup KB106555