AT Command May Fail Copying Files to a LAN Manager Server (105995)
The information in this article applies to:
- Microsoft Windows NT Server 3.1
- Microsoft Windows NT Server 3.5
- Microsoft Windows NT Server 3.51
- Microsoft Windows NT Server 4.0
- Microsoft Windows NT Workstation 3.1
- Microsoft Windows NT Workstation 3.5
- Microsoft Windows NT Workstation 3.51
- Microsoft Windows NT Workstation 4.0
This article was previously published under Q105995 SYMPTOMS
If you use the AT command to schedule a batch file that copies files
to a Microsoft LAN Manager server in a different domain, the batch
file may fail and you will receive an "Access Denied" error message.
However, if you execute the batch file from a command prompt, it
successfully copies the files without generating an error message.
Sample batch file:
Net Use z: \\LMServer\Share
copy test.txt z:\
Net Use z: /d
CAUSE
Without domain information for the user account, using the AT command
does not succeed. This is because the account it is trying to validate
is the SYSTEM account. By default, the Schedule service uses the
SYSTEM account for access rights.
WORKAROUND
There are two workarounds for this problem:
- Supply domain information for the user in the NET USE command,
such as the following
Net Use z: \\LMServer\share password /USER:LMDomain\guest
where guest must be a valid account in the "LMDomain" domain.
- Have the Schedule Service log on as a valid account on that
LAN Manager server by doing the following:
- In Control Panel, double-click the Services icon.
- Click the Schedule service, and then click Startup.
- Type the user account on the LAN Manager server (which matches a local account) with sufficient rights and type the appropriate password.
- Restart the service so the changes take effect.
This option does not require changing the command line and will be
permanent unless it is changed.
Modification Type: | Major | Last Reviewed: | 5/6/2003 |
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Keywords: | kbnetwork KB105995 |
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