WinMaster Attempts Illegal Access to Hard Disk (104667)
The information in this article applies to:
- Microsoft Windows NT Server 3.1
- Microsoft Windows NT Workstation 3.1
- Microsoft Windows NT Advanced Server 3.1
This article was previously published under Q104667 SYMPTOMS
WinMaster by the PC-Kwik Corporation causes error messages when you
attempt to install and use it in Windows NT 3.1. The most serious
error message occurs if you try to use the PowerScope tool from the
WinMaster utilities. After you attempt to open the PowerScope icon in
the WinMaster Toolbox, the following error message appears in a dialog
box titled "16 bit Windows Subsystem:"
PowerScope: An application has attempted to directly access the hard
disk, which cannot be supported. This may cause the application to
function incorrectly. Choose 'Close' to terminate application.
This dialog box gives you the options of Close or Ignore. If you
choose Ignore, the PowerScope tool eventually causes a general
protection (GP) fault.
CAUSE
Part of the functionality of WinMaster is to directly read disk
information from the system hard disk in order to provide a disk
directory, memory usage by directory, a disk map displaying usage and
fragmentation, and information about the boot sector. Windows NT,
however, does not allow applications to directly access the hardware.
Therefore, the low-level WinMaster calls to the hard disk are illegal.
RESOLUTION
Currently no workaround or solution to the problem exists. No solution
may be possible because the WinMaster application makes low-level
calls to the hardware, which are not supported in Windows NT.
MORE INFORMATION
The PowerScope tool has a number of utility buttons including Log
Drive, Directory Tree, and Disk Map. Various errors occur when you
attempt to use each of these utilities. When you choose the Log Drive
button, the following error message appears:
PowerScope! Error updating drive entry. Please update entire list.
When you choose OK in this dialog box, a second error message appears
which states:
PowerScope! Unable to Log Drive!
If you choose on the Directory Tree button, you will get the following
GP fault message:
POWERSCO caused a General Protection Fault in module PSCOPEW.EXE at
xxxx:xxxx. [where the x's designate a hexadecimal memory address]
When you select the Disk Map option, you will receive the following
error message:
Unable to Lock map buffer!
This error message is followed by the following error message:
Unable to lock FAT buffer!
A GP fault identical to the one listed above will appear at this
point. The memory address may vary, but the other information as
listed above will be the same.
Microsoft has confirmed this to be a problem in Windows NT. We are
researching this problem and will post new information here as it
becomes available.
The PC-Kwik products included here are manufactured by vendors
independent of Microsoft; we make no warranty, implied or otherwise,
regarding these products' performance or reliability.
Modification Type: | Major | Last Reviewed: | 4/8/2004 |
---|
Keywords: | kb3rdparty KB104667 |
---|
|