BUG: The print job is not released to the printer in Visual FoxPro (102203)
The information in this article applies to:
- Microsoft Visual FoxPro for Windows 3.0
- Microsoft Visual FoxPro for Windows 5.0
- Microsoft Visual FoxPro for Windows 5.0a
- Microsoft Visual FoxPro for Windows 6.0
- Microsoft Visual FoxPro for Windows 7.0
- Microsoft Visual FoxPro 8.0
- Microsoft Visual FoxPro 9.0 Professional Edition
- Microsoft FoxPro for Windows 2.5
- Microsoft FoxPro for Windows 2.5a
- Microsoft FoxPro for Windows 2.5b
- Microsoft FoxPro for Windows 2.6
- Microsoft FoxPro for MS-DOS 2.0
- Microsoft FoxPro for MS-DOS 2.5
- Microsoft FoxPro for MS-DOS 2.5a
- Microsoft FoxPro for MS-DOS 2.5b
- Microsoft FoxPro for MS-DOS 2.6
- Microsoft FoxPro for UNIX 2.6
This article was previously published under Q102203 SYMPTOMS
When you are printing in FoxPro, the print job is not immediately released
to the printer if a print spooler (such as Windows Print Manager) is being
used.
NOTE: Print spoolers are often used in network environments.
CAUSE
FoxPro still has a current connection to the spooler. Until this connection
is terminated, the spooler will not release the print job.
RESOLUTION
To resolve this problem, do one of the following:
- Issue the SET PRINTER TO command without any other parameters; for
example:
REPORT FORM test TO PRINTER
SET PRINTER TO
- Quit FoxPro. This will terminate FoxPro's connection to the spooler and
the print job will be sent to the printer.
- If you are using FoxPro for Windows, under Windows 3.x, turn off Print
Manager in the Windows Control Panel by double-clicking the Printers
icon and then clearing the Use Print Manager check box.
- Issue a RUN command; for example:
NOTE: Using the RUN command will bring up an MS-DOS session.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 1/31/2005 |
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Keywords: | kbBug kbnetwork kbprint KB102203 |
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