Error Creating System Disk in WFW File Manager (102015)



The information in this article applies to:

  • Microsoft Windows NT Server 3.1
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows for Workgroups 3.1
  • Microsoft Windows 3.1

This article was previously published under Q102015

SYMPTOMS

When you boot your computer from an MS-DOS system disk created under Windows version 3.1 (or Windows for Workgroups [WFW] version 3.1) File Manager, the following error message appears:
BOOT: Couldn't find NTLDR
Please insert another disk

CAUSE

This problem occurs when you are using Windows NT's OS Loader version 3.1. Windows NT OS Loader replaces the MS-DOS files on the physical boot sector of the hard disk with NTLDR. When you boot your system, NTLDR loads and searches for BOOT.INI. The BOOT.INI file contains which operating systems are available, where to find them, the default OS, and the time out if no selection is made.

If Windows NT is selected, NTLDR runs NTDETECT.COM, which collects information on the hardware components installed in the machine. NTDETECT.COM then passes a list of hardware back to NTLDR and this information is used to load NTOSKRNL.EXE and the hardware abstraction layer (HAL) starting Windows NT.

If MS-DOS is selected, then NTLDR loads BOOTSECT.DOS; this is where the information in the physical boot sector was moved to. This starts a normal MS-DOS boot sequence.

When a system disk is created in Windows for Workgroups File Manager, the boot sector from the hard drive is copied to sector 0 of the floppy disk, this causes the boot to fail because it can't find NTLDR or BOOT.INI. Also, a DIR /AH (hidden files) of the disk looks normal.

WORKAROUND

Run the MS-DOS Command Prompt from inside WFW or exit back to MS-DOS and use the SYS command to create the boot disk.

Steps to Reproduce Problem

  1. From File Manager Disk menu, choose Format Disk or Make System Disk.
  2. Select the appropriate disk drive.
  3. If you selected Format Disk, then check the box marked Make System Disk.
  4. Choose OK.
  5. Reboot the system and the error message will appear.

STATUS

Microsoft has confirmed this to be a problem in Windows and Windows for Workgroups version 3.1. This problem was corrected in Windows for Workgroups version 3.11.

Modification Type:MajorLast Reviewed:12/15/2003
Keywords:kbinterop KB102015