ACC: "Btrieve-Out of Resources" Error Msg with Attached Table (101405)
The information in this article applies to:
- Microsoft Access 1.0
- Microsoft Access 1.1
- Microsoft Access 2.0
This article was previously published under Q101405
Moderate: Requires basic macro, coding, and interoperability skills.
SYMPTOMS
When you open an attached Btrieve table, you may receive the following
error message:
Btrieve-Out of Resources
CAUSE
If you are using compressed Btrieve files, you must be sure that the
compression buffer Btrieve is using is adequate for your data. The
buffer size must be at least as large as the largest record in your
data files.
RESOLUTION
To ensure proper operation, set the compression buffer size option (/u) in
the [btrieve] section of your WIN.INI file (for Btrieve version 5.1x), or
your NOVDB.INI file (for Btrieve version 6.x). The units for this setting
are kilobytes, so if your largest record is 2K, you would add /u:2 to the
Btrieve options line in the .INI file.
MORE INFORMATION
Btrieve is manufactured by Pervasive Software, a vendor independent
of Microsoft; we make no warranty, implied or otherwise, regarding this
product's performance or reliability.
REFERENCES
For more information about setting options, see the topic "Setting Btrieve
Options in WIN.INI" in the BTRIEVE.TXT file, included with Microsoft Access
version 1.1. In Microsoft Access version 2.0, refer to the ACREADME.HLP
file.
Modification Type: | Major | Last Reviewed: | 5/6/2003 |
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Keywords: | kb3rdparty kberrmsg kbprb KB101405 |
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