ACC: "Internal Database Error (-5001)" Msg Using Btrieve NLM (97531)
The information in this article applies to:
- Microsoft Access 1.0
- Microsoft Access 1.1
- Microsoft Access 2.0
This article was previously published under Q97531
Moderate: Requires basic macro, coding, and interoperability skills.
SYMPTOMS
You receive the following error message when you are using the Btrieve
Network Loadable Module (NLM) with Microsoft Access version 1.0:
Internal Database Error (-5001)
NOTE: You might also encounter an "Unexpected Error from External Database
Driver [1017]" error message if you are missing the WBTRVRES.DLL file. This
message occurs in Microsoft Access versions 1.0, 1.1, and 2.0.
CAUSE
You do not have correct versions of the Brequest.exe, Wbtrcall.dll, and
Wbtrvres.dll files. In order for the Btrieve NLM to function properly with
Microsoft Access, Microsoft recommends that the NLM requester (client) use
Brequest.exe, Wbtrcall.dll, Wbtrvres.dll version 6.0, and Btrieve.nlm
version 5.15.
RESOLUTION
Use the following procedure to obtain the correct versions of these
Btrieve files:
- Call Btrieve Technologies, Inc at 1-800-287-4383 and ask for the
file Bt515.exe.
- Once you have the Bt515.exe file, copy it to an empty directory.
Then unzip the file by running Bt515.exe. Bt515.exe is a
self-extracting zip file that will decompress several files and place
them in directories.
- After the files are extracted, follow the instructions in the
Bt515.txt file to properly install these files and for information
on how to apply patches to the Btrieve.nlm file on your server.
- Add the following lines to your Win.ini file:
[BREQUESTDPMI]
datalength=4096
tasks=10
local=no
chkparms=no
MORE INFORMATION
Btrieve is manufactured by Pervasive Software, a vendor independent of
Microsoft; we make no warranty, implied or otherwise, regarding this
product's performance or reliability.
Modification Type: | Major | Last Reviewed: | 5/9/2003 |
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Keywords: | kb3rdparty kberrmsg kbprb KB97531 |
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