When you visit a Web page that uses a custom pop-up object, Internet Explorer 6 closes unexpectedly (923996)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Service Pack 2
    • Microsoft Windows Server 2003 SP1

SUMMARY

When you visit a Web page that uses a custom pop-up object, Microsoft Internet Explorer 6 closes unexpectedly and generates an error in the Mshtml.dll file. This problem occurs after you install security update 918899 on a Windows XP Service Pack 2 (SP2)-based or a Windows Server 2003 Service Pack 1 (SP1)-based computer. A hotfix is available if you are severely affected by this problem. Otherwise, we recommend that you wait for the next cumulative security update for Internet Explorer.

SYMPTOMS

You visit a Web page that uses a custom pop-up object. Or, on the home page of a Microsoft Windows SharePoint Services Web site, you click Modify Shared Page, and then click Design this Page. In both scenarios, Microsoft Internet Explorer 6 closes unexpectedly. Additionally, you may receive the following error message:
Internet Explorer has encountered a problem and needs to close. We are sorry for the inconvenience.
If you were in the middle of something, the information you were working on might be lost.
Please tell Microsoft about this problem.
We have created an error report that you can send to help us improve Internet Explorer. We will treat this report as confidential and anonymous.
To see what data this error report contains, click here.
The error report contains the following error-signature information.
ProductAppNameAppVerModNameModVerOffset
Windows XP SP2Iexplore.exe6.00.2900.2180Mshtml.dll6.0.2900.29630006d031
Windows Server 2003 SP1Iexplore.exe6.0.3790.1830Mshtml.dll6.0.3790.2759000b19d6
This problem occurs after you install security update 918899 on a Microsoft Windows XP Service Pack 2 (SP2)-based or a Microsoft Windows Server 2003 Service Pack 1 (SP1)-based computer. For more information about security update 918899, click the following article number to view the article in the Microsoft Knowledge Base:

918899 MS06-042: Cumulative security update for Internet Explorer


For example, after you install security update 918899, this problem may occur when you visit a Web page that uses the custom menus, the custom message boxes, or the custom tooltips that are documented on the following Microsoft Web site:

CAUSE

This problem occurs because of a regression error in security update 918899.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next cumulative security update for Internet Explorer that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

The following list contains prerequisites for the hotfix:
  • Internet Explorer 6
  • Security update 918899
  • Windows XP SP2 or Windows Server 2003 SP1

Restart requirement

You must restart the computer after you apply this hotfix.

Deployment information

To install this hotfix without any user interaction, without a display, and without restarting the computer, use the /quiet and /norestart command-line options. For example, to do this on a computer that is running an x86-based version of Windows XP, type the following at a command prompt:

WindowsXP-kb923996-x86-enu.exe /quiet /norestart

For more information about command-line options to install this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:

262841 Command-line switches for Windows software update packages

To verify that this hotfix is installed, confirm that the files that are listed in the "File information" section are installed in the %systemroot%\System32 folder on the computer and that the following registry key exists:

Windows XP SP2

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP\SP3\KB923996

Windows Server 2003 SP1

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows Server 2003\SP3\KB923996

Removal information

To remove this update, follow these steps:
  1. Click Add or Remove Programs in Control Panel.
  2. Remove Windows XP Hotfix - KB923996. If hotfixes are not listed in Add or Remove Programs, click to select the Show Updates check box.
You can also use the Spuninst.exe utility to remove this hotfix. The Spuninst.exe utility is located in the %Windir%\$NTUninstallKB923996$\Spuninst folder. To remove this hotfix without any user interaction, without a display, and without restarting the computer, use the /quiet and /norestart command-line options. For example, to do this on a computer that is running an x86-based version of Windows XP, type the following at a command prompt:

%windir%\$NTUninstallKB923996$\Spuninst\Spuninst.exe /quiet /norestart

For more information about how to use command-line options to remove this hotfix, type the following at a command prompt:

%windir%\$NTUninstallKB923996$\Spuninst\Spuninst.exe /?

Hotfix replacement information

This hotfix does not replace a previously released software update.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows XP SP2 (x86-based)
File nameFile versionFile sizeDateTimeSP requirementService branch
Mshtml.dll6.0.2900.29753,054,08016-Aug-200612:02SP2SP2GDR
Mshtml.dll6.0.2900.29753,058,17616-Aug-200612:09SP2SP2QFE
Windows Server 2003 SP1 (x86-based)
File nameFile versionFile sizeDateTimeSP requirementService branch
Mshtml.dll6.0.3790.27713,152,38416-Aug-200614:05SP1SP1GDR
Mshtml.dll6.0.3790.27713,153,92016-Aug-200614:33SP1SP1QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

By default, the error message that is mentioned in the "Symptoms" section is displayed when an unrecoverable error occurs in Internet Explorer. The error message includes an option to send information about the problem to Microsoft. Microsoft analyzes information about these types of errors to try to identify the causes. For information about the data collection policy for error reporting, visit the following Microsoft Web site: The following errors are written to the Application log by Windows Error Reporting:

Windows XP SP2
Date: Date
Time: Time
Type: Error
User: N/A
Computer: Computer name
Source: Application Error
Category: None
Event ID: 1000
Description: Faulting application Iexplore.exe, version 6.00.2900.2180, faulting module Mshtml.dll, version 6.0.2900.2963, fault address 0x0006d031.
Date: Date
Time: Time
Type: Error
User: N/A
Computer: Computer name
Source: Application Error
Category: None
Event ID: 1001
Description: Fault bucket 315386536

Windows Server 2003 SP1
Date: Date
Time: Time
Type: Error
User: N/A
Computer: Computer name
Source: Application Error
Category: None
Event ID: 1000
Description: Faulting application Iexplore.exe, version 6.0.3790.1830, faulting module Mshtml.dll, version 6.0.3790.2759, fault address 0x000b19d6.
Date: Date
Time: Time
Type: Error
User: N/A
Computer: Computer name
Source: Application Error
Category: None
Event ID: 1001
Description: Fault bucket 315429791
Notes
  • IT administrators can use the Corporate Error Reporting (CER) tool to manage error reports and error messages that are created by the Windows Error Reporting (WER) client in Microsoft Windows XP, in Microsoft Windows Server 2003, and in error-reporting (ER) clients that are included in other Microsoft programs. If error-reporting clients are configured to work together with CER 2.0, error reports are redirected to a CER-shared folder instead of being redirected to Microsoft. For more information, visit the following Microsoft Web site:
  • If you are using CER, you do not see event ID 1001.
  • If Windows Error Reporting is disabled, you may not receive any visual notification when an unrecoverable error occurs. In some cases, you may receive an error message that resembles the following:
    IEXPLORE.EXE - Application Error
    The instruction at "0x7dc9d031" referenced memory at "0x00000020". The memory could not be "read".
    Click on OK to terminate the program.
    Click on CANCEL to debug the program.
    Additionally, an error that resembles the following may be written to the Application log:
    Date: Date
    Time: Time
    Type: Information
    User: N/A
    Computer: Computer name
    Source: Application Popup
    Category: None
    Event ID: 26
    Description: Application popup: IEXPLORE.EXE - Application Error : The instruction at "0x7dc9d031" referenced memory at "0x00000020". The memory could not be "read".
    If you disable error reporting, a Drwtsn32.log file, a User.dmp file, or both files may be created, depending on the system configuration.
For more information about event ID 1000 and about event ID 1001, visit the following Microsoft Web site: For more information about how to disable error reporting, click the following article numbers to view the articles in the Microsoft Knowledge Base:

310414 How to configure and use error reporting in Windows XP

276550 Description and availability of Internet Explorer Error Reporting tool

325075 How to disable error reporting by the Application Error Reporting tool in Office XP

For more information about the Drwtsn32.log file and about the User.dmp file, click the following article number to view the article in the Microsoft Knowledge Base:

308538 Description of the Dr. Watson for Windows (Drwtsn32.exe) tool


Modification Type:MinorLast Reviewed:9/7/2006
Keywords:kbExpertiseBeginner kbWinXPsp3fix kbWinXPpreSP3fix kberrmsg kbOCAbucket kbfix kbbug kbQFE kbhotfixserver kbpubtypekc KB923996 kbAudEndUser