A Windows Server 2003-based terminal server stops responding to new connection requests, and the logon window does not appear (923630)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003 SP1

SYMPTOMS

When you try to connect to a Microsoft Windows Server 2003-based terminal server, the server stops responding, and the logon window does not appear. Additionally, when you use the query session command at the command prompt to check session states, you see that the state for many sessions is displayed as Down.

CAUSE

After you log off a terminal service session from a Windows Server 2003-based terminal server, the session is not correctly ended. Over time, this may cause your terminal server to stop responding to new connection requests. This problem occurs because of a problem with how the system handles hotkeys.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows Server 2003 Service Pack 1 (SP1) installed to apply this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Gdi32.dll5.2.3790.2762282,11202-Aug-200617:12x86SP1
Win32k.sys5.2.3790.27621,850,88002-Aug-200612:44x86SP1
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.2762906,24002-Aug-200603:11IA-64SP1Not Applicable
Win32k.sys5.2.3790.27625,546,49602-Aug-200603:11IA-64SP1Not Applicable
Wgdi32.dll5.2.3790.2762285,18402-Aug-200603:11x86SP1WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.2762610,30402-Aug-200603:10x64SP1Not Applicable
Win32k.sys5.2.3790.27624,529,66402-Aug-200603:10x64SP1Not Applicable
Wgdi32.dll5.2.3790.2762285,18402-Aug-200603:10x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/6/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB923630 kbAudITPRO