Antigen 8.0 for Microsoft Exchange does not scan some storage groups after you fail over many cluster nodes in an active/passive server cluster (923181)



The information in this article applies to:

  • Sybari Antigen 8.0 for Microsoft Exchange

SYMPTOMS

After you fail over many cluster nodes to the passive node of an active/passive server cluster, Sybari Antigen 8.0 for Microsoft Exchange does not scan some of the Microsoft Exchange Server storage groups on the formerly passive cluster node.

You expect Antigen 8.0 for Microsoft Exchange to scan all the storage groups that are running on the cluster node.

You experience this problem when the failover process causes more than 16 Exchange Server storage groups to be hosted by a single cluster node.

CAUSE

This problem occurs because of a storage limitation in Antigen 8.0 for Microsoft Exchange. Antigen 8.0 for Microsoft Exchange can only store information about 16 storage groups in the Scanjobs.adb file.

Generally, you do not experience a problem because of this limitation. By default, Microsoft Exchange Server 2003 and Microsoft Exchange 2000 Server may have up to four storage groups.

Note Exchange Server 2003 may also have a fifth storage group for use as the recovery storage group.

However, you may experience a problem with this limitation in a cluster failover scenario. Consider the following scenario:
  • You have an active/passive cluster that has five active cluster nodes and one passive cluster node.
  • Each active cluster node hosts Exchange Server.
  • Each Exchange Server instance has four storage groups.
  • All the active cluster nodes fail over to the passive cluster node.
In this scenario, the Scanjobs.adb file on the passive cluster node can hold the information about the Exchange Server storage groups on the first four active cluster nodes that fail over. However, when the fifth active cluster node fails over, the Scanjobs.adb file on the passive cluster node cannot hold the information about the remaining four Exchange Server storage groups.

RESOLUTION

An update is available for Antigen 8.0 for Microsoft Exchange. To obtain this update, contact Microsoft Product Support Services. For more information about how to contact Microsoft Product Support Services, visit the following Microsoft Web site:

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:8/21/2006
Keywords:kbClustering kbtshoot kbfix kbBug kbprb KB923181 kbAudITPRO