The Exchange Information Store service does not start, and an event ID 5000 message is logged in Exchange Server 2003 SP2 (923171)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Service Pack 2

SYMPTOMS

After you upgrade to Microsoft Exchange Server 2003 Service Pack 2 (SP2), the Microsoft Exchange Information Store Service may not start. Additionally, the following event is logged in the Application log:Event ID: 5000
Source: Exchange IS
Description: Unable to initialize the store service. Failed to search for MSEXCHUCE in DS. 0x80004005

CAUSE

This problem may occur if a query for the Intelligent Message Filter (IMF) is made against a domain controller that is under a heavy load. When the Exchange Information Store service in Exchange Server 2003 SP2 starts, it issues a query to check an attribute for the IMF. This query uses lots of resources. When this query is made against a domain controller that is already under heavy load, the domain controller may not respond to the query in a timely manner. Therefore, a time-out may occur during the LDAP query. If a time-out occurs several times, the Exchange Information Store service may not start.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Hotfix installation information

After you apply this hotfix, the query uses an indexed attribute. Therefore, the domain controller does not have to enumerate as many objects to build the response.

Prerequisites

You must install Microsoft Exchange Server 2003 Service Pack 2 (SP2) before you install the hotfix.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply the hotfix. However, the Microsoft Exchange Information Store service and all dependent services will be restarted.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Exosal.dll6.5.7651.4570,14424-Aug-200622:21x86
Exspmsg.dll6.5.7233.418,19208-Aug-200522:02x86
Mdbmsg.dll6.5.7651.453,372,54424-Aug-200616:54x86
Store.exe6.5.7651.455,258,75224-Aug-200622:22x86

WORKAROUND

To work around this problem, you can temporarily hardcode the Directory Access (DSAccess) component to query domain controllers that are not heavily loaded. You must select domain controllers that can respond to the query before the two-minute time-out period expires. To do this, follow these steps:
  1. Start Exchange System Manager.
  2. Expand Administrative Groups, expand First Administrative Group, and then expand Servers.
  3. Right-click the server that you want, and then click Properties.
  4. Click the Directory Access tab.
  5. In the Show box, click Domain Controllers.
  6. Click to clear the Automatically discover servers check box, and then click Yes when you receive the warning message.
  7. Click Advanced, and then click Find Now.
  8. In the Search results box, click an appropriate entry for a Microsoft Windows Server-based computer, and then click OK three times.
  9. Exit Exchange System Manager.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that Microsoft uses for software that is corrected after it is released, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about the naming schema for Exchange software updates, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:9/22/2006
Keywords:kbQFE kbfix kbBug kbhotfixserver kbpubtypekc KB923171 kbAudITPRO