The criteria in an event rule does not work if the criteria content is text in MOM 2005 (922640)



The information in this article applies to:

  • Microsoft Operations Manager 2005

SYMPTOMS

You try to set criteria in an event rule in Microsoft Operations Manager (MOM) 2005. If the criteria content is text that is generated from a GUID, the criteria may not work.

This problem occurs when you enable MOM 2005 to resolve GUIDs as described in Microsoft Knowledge Base article 904740. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

904740 How to enable Microsoft Operations Manager 2000 and Microsoft Operations Manager 2005 to resolve security GUIDs and SIDs


Additionally, a message that resembles the following message may be logged in the MOM event log:Object Open: Object Server: DS Object Type: organizationalUnit Object Name: OU=secure cell long,OU=Company A,OU=Test Users,DC=LY,DC=com New Handle ID: 0 Operation ID: {0,1108776} Process ID: 264 Primary User Name: LYDC1$ Primary Domain: LY Primary Logon ID: (0x0,0x3E7) Client User Name: Administrator Client Domain: LY Client Logon ID: (0x0,0x10EB1B) Accesses WRITE_OWNER Privileges SeTakeOwnershipPrivilege Note Generally, the object name appears instead of the GUID in the event log in MOM 2005.

CAUSE

This problem occurs because the GUID is resolved to text before the GUID is sent back to the MOM server. However, the GUID is not resolved before rule matching occurs.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Operations Manager 2005 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

The hotfix requires Microsoft Operations Manager 2005 Service Pack 1.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
283843_enu_alpha_zip.exe1.3.1.45,462,42119-Sep-200609:25x86
After you install this hotfix, the following file will have the file attributes or later that are listed in the following table.
File nameFile versionFile sizeDateTimePlatform
Mom2005-sp1-kb922640-x86-ia64-enu.msiNot Applicable2,277,37615-Aug-200602:08Not Applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/27/2006
Keywords:kbfix kbExpertiseInter kbQFE kbOpman2005spfix kbhotfixserver KB922640 kbAudITPRO