You receive an error message the first time that you try to use the Remote Assistance feature to offer assistance to a user whose computer is running Windows XP (921982)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

You are using a computer that is running Microsoft Windows XP. You try to use the Remote Assistance feature to offer remote assistance to a user whose computer is also running Windows XP. However, the first time that you try to connect to the user's computer, you receive one of the following error messages:
A Remote Assistance connection could not be established. You may want to check for network issues or determine if the invitation expired or was cancelled by the person who sent it.
You have been disconnected from Name's computer. For more information, contact Name.
If you try again, you can successfully connect to the computer and offer assistance to the user.

CAUSE

This problem occurs if the following conditions are true:
  • The Remote Desktop feature is not enabled on the user's computer.
  • The connection attempt times out before the Remote Desktop Help Session Manager service on the user's computer starts.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Windows XP with Service Pack 2 (SP2) to install this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirement
Helpsvc.exe 5.1.2600.2946 744,44806-Jul-200608:54x86SP2
Sessmgr.exe 5.1.2600.2946 141,31206-Jul-200608:49x86SP2

WORKAROUND

To work around this problem, enable the Remote Desktop feature on the user's computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about terminology that Microsoft uses to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:7/26/2006
Keywords:kbWinXPpreSP3fix kbfix kbbug kbQFE kbhotfixserver kbpubtypekc KB921982 kbAudITPRO