Error message when you try to close a Task activity in Microsoft CRM 3.0: "Server Error in '/' Application" (921545)



The information in this article applies to:

  • Microsoft CRM 3.0

SYMPTOMS

When you try to close a Task activity in Microsoft Dynamics CRM 3.0, you receive the following error message:
Microsoft CRM Unhandled Error Details:
Server Error in '/' Application.

Server was unable to process request.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
Exception Details: System.Web.Services.Protocols.SoapException: Server was unable to process request.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[SoapException: Server was unable to process request.] System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) +1491
System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) +218
Microsoft.Crm.Platform.Proxy.TaskWebService.Retrieve(Guid id, ColumnSetBase columnSet) +100
Microsoft.Crm.Application.SMWrappers.Task.OMRetrieve(Guid id, ColumnSet columnSet) +54
Microsoft.Crm.Application.SMWrappers.ObjectBase.OMRetrieve(Guid id) +34
Microsoft.Crm.Application.SMWrappers.ObjectBase.InternalRetrieve(String id, String columnSet) +72
Microsoft.Crm.Application.Platform.ActivityBase.InternalRetrieve(String id, String columnSet) +25
Microsoft.Crm.Application.Platform.Entity.Retrieve(String columnSet) +126
Microsoft.Crm.Application.Platform.Entity.Retrieve() +10
Microsoft.Crm.Web.Activities.BasicActivityPage.ChangeState(Object sender, DataEventArgs e) +253 Microsoft.Crm.Application.Forms.DataEventProcessor.Raise(FormEventId eventId, FormState state, User user, String objectId, Entity entity) +176
Microsoft.Crm.Application.Forms.AppForm.RaiseDataEvent(FormEventId eventId) +89
Microsoft.Crm.Application.Forms.EndUserForm.Initialize(Entity entity) +56
Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity, String formId, String formType) +83
Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity) +13
Microsoft.Crm.Web.Activities.BasicActivityPage.ConfigureForm() +198
Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e) +30
System.Web.UI.Control.PreRenderRecursiveInternal() +54
System.Web.UI.Page.ProcessRequestMain() +1499

CAUSE

This problem occurs if the following conditions are true:
  • You have upgraded Microsoft CRM 3.0
  • You have installed the c360 Search Pac tool.

RESOLUTION

To resolve this problem, follow these steps.

Note After you complete these steps, the data that is in the cfsdirectioncode field will be lost.
  1. On the Microsoft CRM Web client, click Settings, click Customization, and then click Customize Entities.
  2. In the Customization Entries dialog box, double-click Task.
  3. In the Entity:Task dialog box, click Attributes on the Details menu.
  4. Select the cfsdirectioncode picklist attribute, and then click Delete.
  5. Click Save and Close.
  6. Click Publish.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

916572 Error message when you complete Task activities in Microsoft Dynamics CRM 3.0: "Microsoft CRM Unhandled Error Details: Server Error in '/' Application"


Modification Type:MajorLast Reviewed:6/27/2006
Keywords:kberrmsg kbMBSMigrate kbprb kbtshoot KB921545 kbAudEndUser kbAudKnowledgeWorker