Error message when you run the Dirquota.exe tool in Windows Server 2003 R2: "STOP 0x50" (921478)



The information in this article applies to:

  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition

SYMPTOMS

Consider the following scenario:
  • You have a Microsoft Windows Server 2003 R2-based computer on which File Server Resource Manager (FSRM) is installed.
  • You run the Dirquota.exe tool on a volume that is copied from another computer.
In this scenario, the computer stops responding (hangs). Additionally, you receive a Stop error message that resembles the following:
STOP 0x00000050 (parameter1, parameter2, parameter3, parameter4)
Page Fault in Non-Paged Area
Note The parameter values may vary.

CAUSE

This problem occurs if the file system filter manager incorrectly calculates the string length of file names when a hard link is created or during any renaming operation. Specifically, this problem occurs if the stream name is longer than the file name.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

Windows Server 2003, Itanium-based version
File nameFile versionFile sizeDateTime
Fltmgr.sys5.2.3790.2730470,01621-Jun-200601:56
Windows Server 2003, x64-based version
File nameFile versionFile sizeDateTime
Fltmgr.sys5.2.3790.2730226,81621-Jun-200601:52
Windows Server 2003, x86-based version
File nameFile versionFile sizeDateTime
Fltmgr.sys5.2.3790.2730129,53621-Jun-200610:21
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the description of the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:8/18/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB921478 kbAudITPRO