You may receive an error message and Visual Studio 2005 may close unexpectedly when you request Help pages in the Visual Studio 2005 IDE or when you click a link in the Visual Studio 2005 IDE or in Document Explorer 2005 (921385)



The information in this article applies to:

  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual Studio 2005 Express Edition

SYMPTOMS

You may receive an error message and Visual Studio 2005 may close unexpectedly when one of the following conditions is true:
  • You click a link on the Start Page in the Microsoft Visual Studio 2005 IDE (Devenv.exe).
  • You click a link in Microsoft Document Explorer 2005 (Dexplore.exe).
  • You request the Help pages in the Visual Studio 2005 IDE by pressing F1.
  • You click How Do I on the Help menu.
The error message resembles the following:
Attempted to Read or Write protected Memory. This is often an indication that other memory is corrupt.
Note The faulty module is Msenv.dll.

CAUSE

This problem occurs because a rootkit is installed on your computer. A rootkit is a set of software tools that a third-party may use after the third-party gains access to a computer. This third-party is usually an intruder. These tools can hide running processes, files, or system data. This behavior helps an intruder maintain access to a computer without the knowledge of the user.

RESOLUTION

To resolve this problem, clean the rootkit from the computer.

To do this, follow these steps:
  1. Visit the following Microsoft Web site:
  2. Click Protection Scan.
  3. Read the service beta agreement, and then click Accept.
  4. Click Install Now.
  5. Click Install in the dialog box that appears.
  6. When the scanner installation is completed, click Launch Scanner.

MORE INFORMATION

For more information about the potential exploit vectors that may be exposed by rootkits and for general guidelines on remediating rootkit vulnerabilities, visit the following Microsoft TechNet Web site: http://www.microsoft.com/technet/community/columns/sectip/st1005.mspx.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:7/6/2006
Keywords:kbBug kbtshoot kbprb KB921385 kbAudDeveloper kbAudITPRO