You may receive an error message when use an answer file to install SQL Server 2005 when the Visual Studio 2005 Team Foundation Server language and the operating system server language are different (921315)



The information in this article applies to:

  • Microsoft Visual Studio 2005 Team System Team Foundation:

SYMPTOMS

Consider the following scenario. You use an answer file to install Microsoft SQL Server 2005. The Microsoft Visual Studio 2005 Team Foundation Server language and the operating system server language are different. In this scenario, you may receive the following error message:
SQL Server Setup could not validate the service accounts. Either the service accounts have not been provided for all the services being installed, or the specified username or password is incorrect. For each service, specify a valid username, password, and domain, or specify a built-in system account.

CAUSE

This problem occurs because you cannot use a single answer file for all localized operating systems when you install SQL Server 2005. For example, English user account names can cause the setup process to fail on non-English editions of Microsoft Windows Server 2003.

RESOLUTION

To resolve this problem, modify the answer file to use the correct localized names for the specified service accounts.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how to install SQL Server 2005 by using an answer file, see the following sections in the Visual Studio Team Foundation Installation Guide.

Single-server deployment

See the "To install Microsoft SQL Server 2005 using an answer file" section in the "How to: Install Microsoft SQL Server 2005 for Team Foundation Server (Single-Server Deployment)" topic.

Dual-server deployment

See the "To install Microsoft SQL Server 2005 using an answer file" section in the "How to: Install Microsoft SQL Server 2005 for Team Foundation Server (Dual-Server Deployment)" topic.

Modification Type:MajorLast Reviewed:8/4/2006
Keywords:kbtshoot kberrmsg kbBug kbprb KB921315 kbAudDeveloper kbAudITPRO