FIX: The PSXRUN process may not stop when you try to stop a POSIX-based application that is running as a Windows service in Windows Services for UNIX 3.5 (921207)



The information in this article applies to:

  • Microsoft Windows Services for UNIX 3.5

SYMPTOMS

In Microsoft Windows Services for UNIX 3.5, you try to stop a Portable Operating System Interface (POSIX)-based application that is running as a Windows service. When you do this, the PSXRUN process may not stop. Additionally, the PSXRUN process may continue to show the STOPPING status.

This problem occurs when the following conditions are true:
  • You use the PSXRUN process to start the POSIX-based application as a Windows service.
  • You run the PSXRUN process on a multiprocessor-based computer.

CAUSE

This problem occurs because there are two threads in the PSXRUN process that call the SetServiceStatus function, and the two threads are not synchronized. One of the threads should always call the SetServiceStatus function before the second thread calls the SetServiceStatus function.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must be running Windows Services for UNIX 3.5.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Posix.exe8.0.1969.45130,04830-Jun-200612:00x86
Psxdll.dll8.0.1969.45345,08830-Jun-200612:00x86
Psxrun.exe8.0.1969.45104,44830-Jun-200612:00x86
Psxss.exe8.0.1969.45780,80030-Jun-200612:00x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:8/17/2006
Keywords:kbQFE kbhotfixserver kbpubtypekc KB921207 kbAudDeveloper kbAudITPRO