Error message when you try to open a document after you have already opened it one time in Internet Explorer 6: "The page cannot be displayed" (918692)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 Service Pack 1, when used with:
    • Microsoft Windows XP Service Pack 1
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Server
    • Microsoft Windows 2000 Professional
  • Microsoft Windows XP Service Pack 2

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

Consider the following scenario. You use Microsoft Internet Explorer 6 to visit a Web site that contains a link to a document. You click the link to the document, and then click Open to open the document.

For example, you connect to a Microsoft Windows SharePoint Services Web site, and then you click a link to open a document that is located in a document library.

The document opens as expected. Then, you click Back in Internet Explorer. When you click the link to the document again, you receive the following error message:
The page cannot be displayed
You cannot open the document again.

CAUSE

This problem occurs if the following conditions are true:
  • The link to the document contains certain international characters.
  • HTTP compression is enabled on the Web server.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Windows XP with Service Pack 2 (SP2), Windows XP with Service Pack 1 (SP1), or Internet Explorer 6 with Service Pack 1 (SP1) to install this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you have to restart Internet Explorer 6.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows XP with SP2
File nameFile sizeDateTimePlatform
Urlmon.dll615,42410-May-200613:50x86
Internet Explorer with SP1
File nameFile sizeDateTimePlatform
Urlmon.dll463,36010-May-200622:24x86

Enable the hotfix

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
After you install the hotfix, you must enable it. To do this, follow these steps:
  1. Click Start, click Run, type regedit , and then click OK.
  2. Locate, and then click the following registry subkey:

    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\FeatureControl

    Note If any of the subkeys are not present on the computer, create them.
  3. Right-click FeatureControl, point to New, and then click Key.
  4. Type FEATURE_URLMON_DECOMPRESSION_USES_WININET_URL_KB918692, and then press ENTER.
  5. Right-click FEATURE_URLMON_DECOMPRESSION_USES_WININET_URL_KB918692, point to New, and then click DWORD Value.
  6. Type Iexplore.exe, and then press ENTER.
  7. Right-click Iexplore.exe, and then click Modify.
  8. In the Value data box, type 1, and then click OK.
  9. Exit Registry Editor.

WORKAROUND

To work around this problem, disable HTTP compression on the Web server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:9/23/2006
Keywords:kbRegistry kbExpertiseInter kbWinXPpreSP3fix kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB918692 kbAudITPRO