Error message when you try to install Internet Explorer 7 Release Candidate: "Internet Explorer could not be installed" (917925)



The information in this article applies to:

  • Microsoft Internet Explorer 7.0

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you try to install Microsoft Internet Explorer 7 Release Candidate, the installation wizard finishes, but the last screen displays the following error message:
Internet Explorer 7 could not be installed. You must restart your system to confirm that any changes to your system are undone.

After restarting, follow the "Internet Explorer Troubleshooting" shortcut on your desktop to get more information.

CAUSE

This issue may occur when either of the following conditions is true:
  • Permissions for one or more registry subkeys on the computer are restricted in a way that prevents the update of those registry subkeys. A failure to update a registry key may cause the Setup program to fail.
  • Something has caused the computer not to trust the Internet Explorer 7 installation package.

WORKAROUND

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

The steps outlined in this article involve changing permissions on registry keys to allow installation of Internet Explorer 7. Although modifying the permissions is required to install Internet Explorer 7, in some cases these permissions could be configured for a specific reason. Make sure you understand if any such reasons exist and the potential impact of modifying registry permissions before making them. In addition, you can modify registry permissions to allow installation of Internet Explorer 7 and change them back to their original configuration after setup is complete.

Method 1

If you use any antivirus or antispyware programs, disable them before you install Internet Explorer 7 Release Candidate. Then, re-enable them after the installation has finished. Some antivirus and antispyware programs prevent Internet Explorer 7 Release Candidate from successfully installing, even when they are disabled.

For the latest information about these issues, visit the following Microsoft Web site:

Method 2

  1. Determine if there is a problem that is preventing the registry from being updated:
    1. Click Start, click Run, type %windir%\ie7.log, and then click OK to open the ie7.log file.

      Note By default, the ie7.log file is located in the C:\Windows folder.
    2. Press CTRL+END to move to the end of the ie7.log file.
    3. On the Edit menu, click Find.
    4. In the Find what box, type IECUSTOM: Key is still unwriteable.
    5. Under Direction, click Up, and then click Find Next.

      If you find the "Key is still unwriteable" text, this indicates that there is a problem that is preventing the registry from being updated. For example, text that resembles the following in the log file indicates that there is a problem:

      time_stamp: IECUSTOM: Key is still unwriteable registry_subkey

      In this example, registry_subkey is the name of the registry subkey that is causing the problem.

    If you do not find the "Key is still unwriteable" text in the ie7.log file, go to Method 2 for additional troubleshooting steps.
  2. Reset the registry permissions for the registry subkey that has the incorrect permissions. To update the permissions of the registry subkey, follow these steps:
    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then right-click each registry subkey that you noted in step 1e, and then click Permissions on the Edit menu..

      Note The ie7.log file contains the following abbreviations:
      • HKCR = HKEY_CLASSES_ROOT
      • HKLM = HKEY_LOCAL_MACHINE
      • HKCU = HKEY_CURRENT_USER
    3. Under Group or user names, click Administrators.
    4. Under Permissions for Administrators, make sure that the Allow check box is selected for the following entries:
      • Full Control
      • Read
      Make sure that the Deny check box is not selected for any users or groups.

      For more information about how to modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

      310426 How to use the Windows XP and Windows Server 2003 Registry Editor features

    5. Click Apply, and then click OK.
    6. On the File menu, click Exit.
    7. Try to install Internet Explorer 7 again. You may have to repeat these steps if there are other keys that have permissions that prevent Internet Explorer 7 from installing.

Method 3

Use this method if you receive an error message about the Cryptographic Services that resembles the following error message:
Setup could not verify the integrity of the file Update.inf. Make sure the Cryptographic service is running on this computer
For more information about what to do if you receive this error message, click the following article number to view the article in the Microsoft Knowledge Base:

822798 You cannot install some updates or programs

If the problem still occurs after you follow the steps in Microsoft Knowledge Base article 822798, your installation package may be corrupt. To correct this problem, download Internet Explorer 7 Release Candidate again from the following Microsoft Web site:

Method 4

If none of the workarounds in this article have solved your problem, visit the following Microsoft Internet Explorer 7 Support Web page: You can find additional information, bug reporting methods, and free phone support for Internet Explorer 7 by visiting this Support Web page.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:8/24/2006
Keywords:kbtshoot kbprb KB917925 kbAudEndUser