The Wmiprvse.exe process consumes an ever-increasing amount of memory when you enumerate the MSCluster_ResourceToPossibleOwner class on a Windows Server 2003-based server cluster (917805)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition

SYMPTOMS

Consider the following scenario:
  • You programmatically connect to a Server Cluster Windows Management Instrumentation (WMI) provider.
  • You perform enumerations of the MSCluster_ResourceToPossibleOwner class to monitor state changes in a Microsoft Windows Server 2003-based server cluster.
In this scenario, the Wmiprvse.exe process consumes an ever-increasing amount of available memory. Eventually, your program crashes.

CAUSE

This problem occurs because of a memory leak in the Server Cluster WMI provider (Cluswmi.dll).

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, 32-bit x86 versions
File nameFile versionFile sizeDateTimePlatform
Cluswmi.dll5.2.3790.2678111,61608-Apr-200603:34x86
Windows Server 2003, 64-bit x64 versions
File nameFile versionFile sizeDateTimePlatform
Cluswmi.dll5.2.3790.2678253,44008-Apr-200604:37x64
Windows Server 2003, 64-bit IA-64 versions
File nameFile versionFile sizeDateTimePlatform
Cluswmi.dll5.2.3790.2678393,21608-Apr-200604:37IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbClustering kbWinServ2003preSP2fix kbHotfixServer kbBug kbfix kbQFE kbpubtypekc KB917805 kbAudITPRO