FIX: Error message when you try to connect to an SMB server from an NFS client computer: "Error 67: The network name cannot be found" (917796)



The information in this article applies to:

  • Microsoft Windows Services for UNIX 3.5

SYMPTOMS

Consider the following scenario:
  • A client computer is running the Network File System (NFS) client and the Server Message Block (SMB) client.
  • A server is running the SMB server only.
  • The client computer and the server are not members of a domain, or they are members of different domains that do not have a trust relationship.
  • You log on to the client computer. However, your user name is not known on the server.
  • You try to connect to the server from the client computer by using the \\servername path instead of the \\servername\sharename path.
In this scenario, you receive an error message on the client computer that resembles the following:
Error 67: The network name cannot be found.

CAUSE

This problem occurs because of a problem in the NFS client redirector component of the Client for NFS service.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 R2 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Microsoft Windows Services for UNIX 3.5 installed to apply this hotfix. Additionally, the computer must be running the Client for NFS service.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Nfsrdr.sys8.0.1969.41311,42417-Apr-200611:14Not Applicable

WORKAROUND

To work around this problem, use one of the following methods:
  • Before you use the \\servername path to connect to the server, authenticate the server by running the following command at a command prompt:

    net use \\servername\ipc$ /user:servername\username

  • Remove the NFS client.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

If the NFS client is not installed or the NFS driver is disabled in the registry, you receive an authentication dialog box. For more information about how to disable the NFS driver in the registry, click the following article number to view the article in the Microsoft Knowledge Base:

816071 How to temporarily deactivate the kernel mode filter driver in Windows

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB917796 kbAudITPRO