Errors are logged in the sender.log file and the sched.log file on Systems Management Server 2003 (917435)



The information in this article applies to:

  • Microsoft Systems Management Server 2003
  • Microsoft Systems Management Server 2003 SP1
  • Microsoft Systems Management Server 2003 SP2

SYMPTOMS

On computers that are running Microsoft Systems Management Server (SMS) 2003, errors that resemble the following are logged in the SMS\Logs\sender.log file:
Could not get size of local file E:\SMS\inboxes\schedule.box\tosend\xxxxxxxx.yyy. CFileEnum error 1
Verification reports invalid send requests.

Additionally, errors that resemble the following are logged in the SMS\Logs\sched.log file:
Send request was invalid.

CAUSE

This problem occurs because the SMS Scheduler component deletes instruction files (.I??) that are older than 25 hours. This problem can occur on child primary sites where fan-out routing of site-to-site traffic occurs.

RESOLUTION

Hotfix information

This hotfix is available for Systems Management Server 2003 Service Pack 1 (SP1) and for Systems Management Server 2003 Service Pack 2 (SP2).

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesThis hotfix requires Systems Management Server 2003 Service Pack 1 (SP1) or Systems Management Server 2003 Service Pack 2 (SP2).Restart requirementYou do not have to restart your computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Systems Management Server 2003 Service Pack 1 (SP1)
File nameFile versionFile sizeDateTime
Basesvr.dll2.50.3174.11741,769,47225-Oct-200416:05
Smsse.dll2.50.2726.15440,96025-Dec-200313:30
Systems Management Server 2003 Service Pack 2 (SP2)
File nameFile versionFile sizeDateTimePlatform
Basesvr.dll2.50.4160.21131,769,47228-Feb-200618:00x86
Smsse.dll2.50.2726.999977,82428-Jun-200506:31x86

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The problem discussed in this article applies to the SMS 2003 intruction files (.I??). For more information about a similar problem with .RPG files on SMS 2.0 SP5 and with the original release version of SMS 2003, click the following article number to view the article in the Microsoft Knowledge Base:

886685 Sending request files (.srq) are not processed and site routing packages are deleted before the routing request file is processed in Systems Management Server

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:9/6/2006
Keywords:kbSMSSender kbQFE kbhotfixserver kbpubtypekc KB917435 kbAudITPRO