Error messages when you try to validate a Windows XP-based computer by using Windows Genuine Advantage: "Product Key Inaccessible" and "0x80080212" (917050)



The information in this article applies to:

  • Microsoft Windows Genuine Advantage
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

The Windows Genuine Advantage (WGA) validation check process does not validate successfully on a Microsoft Windows XP-based computer, and you receive one or both of the following error messages:
Product Key Inaccessible
0x80080212

CAUSE

This problem occurs when you do not have the appropriate permissions for the Windows Genuine Advantage\Data folder.

RESOLUTION

To resolve this problem, make sure that you have Read & Execute, List Folder Contents, Read and Write access to the Windows Genuine Advantage\Data folder. To do this, follow these steps.

Windows XP Professional

  1. Click Start, click Run, type the following in the Run dialog box, and then click OK:

    %systemdrive%\Documents and Settings\All Users\Application Data\Windows Genuine Advantage

  2. Right-click the Data folder, and then click Properties.
  3. On the Security tab, click Users (username\Users) in the Group or user names section.
  4. In the Permissions for Users section, make sure that each check box in the Allow column is selected for the following permissions:
    • Read & Execute
    • List Folder Contents
    • Read
  5. Click OK, and then restart the validation check process.

Windows XP Home


Restart your computer in Safe Mode
If the previous steps fail, start the computer in Safe Mode. To start the computer in Safe Mode, follow these steps.

Note Print these instructions before you continue to step 2 because they will not be available after you shut down the computer.
  1. Restart the computer.
  2. On a computer that is configured to start multiple operating systems, press F8 when you see the Startup menu.
  3. Use the arrow keys to select a Safe Mode option, and then press ENTER.

    Note The NUM LOCK functionality must be turned off for the arrow keys to work on the numeric keypad.
  4. For a dual-boot system or a multiple-boot system, use the arrow keys to select the installation that you want, and then press ENTER.
As soon as the computer has been restarted, follow these steps:
  1. Click Start, click Run, type the following in the Run dialog box, and then click OK:

    %systemdrive%\Documents and Settings\All Users\Application Data\Windows Genuine Advantage

  2. Right-click the Data folder, and then click Properties.
  3. On the Security tab, click Users (username\Users) in the Group or user names section.
  4. In the Permissions for Users section, make sure that each check box in the Allow column is selected for the following permissions:
    • Read & Execute
    • List Folder Contents
    • Read
  5. Click OK, and then restart the validation check process.

Modification Type:MinorLast Reviewed:9/7/2006
Keywords:kbValidation kbprb kberrmsg KB917050 kbAudEndUser kbAudITPRO