You may experience an abnormal shutdown on a Windows Server 2003-based computer after the Windows logon screen saver starts (916719)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

You may experience an abnormal shutdown, or "dirty shutdown," of a Microsoft Windows Server 2003-based computer after the Windows logon screen saver starts. This may occur if the following conditions are true:
  • An uninterruptible power supply turns off the Windows Server 2003-based computer.
  • You do not log on at the Windows logon screen after you start the computer.
  • You do not press a key or you do not use the mouse.
  • You are running a program such as an uninterruptible power supply support program that automatically calls the ExitWindowsEx function from the scheduler.
Additionally, after you restart the computer, you may receive the following event message in the System event log:
Event ID: 6006 
Source: Event Log 
Description: The Event log service was stopped. 

Event ID: 6008 
Source: Event Log 
Description: The previous system shutdown at <time> on <date> was unexpected. 

CAUSE

This problem occurs because the Windows logon (Winlogon.exe) process does not ignore the Windows logon screen saver time-out. When the Winlogon.exe process does not ignore the Windows logon screen saver time-out, this causes an abnormal shutdown of the computer.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Winlogon.exe5.2.3790.519497,15214-Apr-200602:59x86
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Winlogon.exe5.2.3790.519641,02413-Apr-200609:10IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

883635 You may experience an abnormal shutdown of your Windows 2000 Server-based computer after the Windows logon screen saver starts


Modification Type:MinorLast Reviewed:9/5/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB916719 kbAudITPRO