Setup may stop responding during a RIS installation at the "Preparing Network Settings" page (916710)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003 Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition

SYMPTOMS

During a Remote Installation Services (RIS) installation operation, Setup may stop responding at the Preparing Network Settings page.

CAUSE

This problem may occur if the following conditions are true:
  • You use the Microsoft Windows Preinstallation Environment (Windows PE).
  • You use the CENATEK RAMDisk tool.
In this scenario, the network adapter may remain active when the computer starts Windows PE. When the Plug and Play (PnP) manager tries to assign the interrupt request level (IRQL) resource to the network adapter, the adapter generates an unexpected interrupt.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.After you download the hotfix described here, follow these steps to resolve this problem:
  1. Double-click the hotfix file to extract the Setupldr.exe file.
  2. Save the file to a familiar location or to a temporary folder.
  3. Locate and right-click the Ntldr file in the \REMINST\Setup\Lang\Images\ImageName\i386\templates folder.
  4. Rename the Ntldr file to ntldr.old.
  5. Copy the Setupldr.exe file to the \REMINST\Setup\Lang\Images\ImageName\i386\templatesfolder.
  6. Right-click Setupldr.exe, click Rename, type ntldr, and then click OK.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Setupldr.efi5.2.3790.2667904,70424-Mar-200602:44Not applicable
Windows Server 2003, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Setupldr.exe5.2.3790.2667279,04024-Mar-200602:43x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

REFERENCES

For more information about the CENATEK RAMDisk tool, visit the following CENATEK Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbWinServ2003preSP2fix kbBug kbfix kbpubtypekc KB916710 kbAudITPRO