Error message when you start Picture It! or Digital Image: "Unable to complete action an unexpected error occurred when trying to create a dialog" (916469)



The information in this article applies to:

  • Microsoft Digital Image Suite 2006
  • Microsoft Digital Image Pro 10
  • Microsoft Digital Image Pro 9
  • Microsoft Digital Image Standard Edition 2006
  • Microsoft Digital Image Starter Edition 2006
  • Microsoft Digital Image Suite 10
  • Microsoft Digital Image Suite 2006 Trial Edition
  • Microsoft Digital Image Suite 9
  • Microsoft Picture It!
  • Microsoft Picture It! 1.0
  • Microsoft Picture It! 2.0
  • Microsoft Picture It! 2000
  • Microsoft Picture It! 99
  • Microsoft Picture It! Digital Image Pro 2003
  • Microsoft Picture It! Digital Image Pro version 7
  • Microsoft Picture It! Express 10
  • Microsoft Picture It! Express 2000
  • Microsoft Picture It! Express 2001
  • Microsoft Picture It! Express 2002 1.0
  • Microsoft Picture It! Express 9
  • Microsoft Picture It! Photo 2001
  • Microsoft Picture It! Photo 2002
  • Microsoft Picture It! Photo Premium 10
  • Microsoft Picture It! Photo Premium 2001
  • Microsoft Picture It! Photo Premium 2002, version 1.0
  • Microsoft Picture It! Photo Premium 9
  • Microsoft Picture It! Photo Premium version 7
  • Microsoft Picture It! Photo version 7
  • Microsoft Picture It! Publishing 2001
  • Microsoft Picture It! Publishing 2001 Gold
  • Microsoft Picture It! Publishing 2001 Platinum
  • Microsoft Picture It! Publishing 2001 Silver
  • Microsoft Picture It! Publishing 2002
  • Microsoft Picture It! Publishing 2002, Gold, version 1.0
  • Microsoft Picture It! Publishing Platinum 2002 1.0

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you start one of the programs that are listed in the "Applies To" section, you receive the following error message:
Unable to complete action an unexpected error occurred when trying to create a dialog

CAUSE

This behavior occurs when one of the following conditions is true:
  • There are too many fonts in the Fonts folder.
  • The "ShowPreview" or "ShowStartup" entries were not created in the registry.
  • The program files have been corrupted.

RESOLUTION

Method 1: Reduce the number of fonts in the Fonts folder

If you have too many fonts in Microsoft Windows, follow these steps.

Step 1: Determine how many fonts are installed

  1. Click Start, click Run, type Fonts, and then click OK.
  2. On the status bar, note how many fonts you have installed on the computer. The status bar is located in the lower-left corner. If you do not see the status bar, click Status Bar on the View menu.
If more than 700 fonts are installed, reduce the number of fonts.

Step 2: Reduce the number of fonts

Note Before you drag more fonts from the Fonts folder, try to determine the fonts that the Microsoft multimedia program uses so that you do not move those fonts. To do this, follow these steps:
  1. Hold down the SHIFT key and insert the installation CD for the program into the CD drive or DVD drive to prevent the program from starting automatically.
  2. Click Start, click Run, type D:\PIP\FONTS, and then click OK. In this example, D is the drive letter for the CD or DVD drive.
  3. Make a note of the name of the fonts that are displayed.
To reduce the number of fonts in the Fonts folder, follow these steps:
  1. Exit any programs that are running on the computer.
  2. Create a new folder on the Microsoft Windows desktop.

    To create a new folder, right-click a blank area on the Windows desktop, click New, click Folder, type the name that you want, and then press ENTER.
  3. Double-click the new folder to open it.
  4. Click Start, click Run, type fonts, and then click OK.
  5. Right-click a blank area of the taskbar, and then click Tile Windows Horizontally.

    Note The Fonts folder window and the window for the folder that you created in step 2 should equally divide the screen.
  6. Right-click and then drag any font that is 3 kilobytes (KB) or smaller from the Fonts folder to the folder that you created in step 2. Then, click Move here. To select multiple fonts, use one of the following methods:
    • To select consecutive font files, click the first item, press and hold down SHIFT, and then click the last item.
    • To select font files that are not consecutive, press and hold down CTRL, and then click each item.
  7. Test to see whether the issue is resolved. If the issue continues to occur, repeat step 6, except drag the following fonts from the Fonts folder to the folder that you created in step 2:
    • Monotype Sorts
    • Monotype Sorts 2
    • Symbol
  8. Test to see whether the issue is resolved. If the issue still occurs, continue with the next step.
  9. If the issue still occurs, repeat step 6, except drag the fonts that the Microsoft program uses, and then remove and reinstall the program.

Method 2: Create the missing registry entries

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following subkey:

    HKEY_CURRENT_USER\Software\Microsoft\PictureIt!\9.0

    Note Step 2 may vary depending on the product and its version that you have installed on the computer. For example, if you have Microsoft Digital Image Pro 9 installed on the computer, the registry subkey will be:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Digital Image\9.0

  3. On the Edit menu, point to New, and then click String Value.
  4. Type ShowPreview, and then press ENTER.
  5. Double-click the entry, type No in the Value data field, and then click OK.
  6. On the Edit menu, point to New, and then click String Value.
  7. Type ShowStartup, and then press ENTER.
  8. Double-click the entry, type No in the Value data field, and then click OK.
  9. Exit Registry Editor, and then start the program.

Method 3: Remove and then reinstall the program

  1. Click Start, click Run, type appwiz.cpl, and then click OK.
  2. Click the Microsoft Picture It! or Microsoft Digital Image program that you want to remove, and then click Remove.
  3. Follow the instructions that appear on the screen to remove the program.
  4. If you are prompted to restart the computer, do not restart the computer now.
Run the Microsoft Windows Installer CleanUp utility to remove the Windows Installer registry settings, and then reinstall the program. To do this, follow these steps:
  1. Download, install, and then run the Windows Installer CleanUp utility to remove the Windows Installer registry settings that are associated with the installation of the product.

    For more information about how to download, install, and use the Windows Installer CleanUp utility, click the following article number to view the article in the Microsoft Knowledge Base:

    290301 Description of the Windows Installer CleanUp Utility

  2. To use the Windows CleanUp utility, follow these steps:
    1. Click Start, point to Programs, and then click Windows Installer Clean Up.
    2. Select the program that you want to remove, and then click Remove.
    3. Click OK, and then click Exit.
    Note Because the Windows Installer CleanUp utility removes Windows Installer-related registry settings and not the program files, make sure that you install the program in the same folder where it was originally installed to prevent duplicate files on the hard disk drive.
If the program in question is not listed in the Windows Installer Cleanup utility, go to the "Perform a clean boot procedure" section. If the Cleanup utility successfully removed the program, go to the "Reinstall" section.

Perform a clean boot procedure

  1. Click Start, click Run, type msconfig, and then click OK.
  2. Click the General tab, click Selective Startup, and then click to clear the following check boxes:
    • Process SYSTEM.INI file
    • Process WIN.INI file
    • Load Startup Items
  3. Click the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.
  4. Click OK, and then click Restart to restart the computer.

    Note To restore the computer to use a typical startup, click Normal Startup - load all device drivers and services on the General tab in the System Configuration Utility. Click OK, and then click Restart to restart the computer.

Reinstall the program

Insert the first disc into the CD or DVD drive. If the Setup program starts automatically, follow the instructions that appear on the screen to install the program.

Note Do not use the Minimal installation option.

If the Setup program does not start automatically, follow these steps:
  1. Click Start, click Run, type D :\setup.exe in the Open box.

    In this example, D is the drive letter of the CD drive or DVD drive.
  2. Click OK.
  3. Follow the instructions that appear on the screen.
We recommend that you use the Typical installation option or the Full installation option to prevent usage issues after you install Picture It! or Digital Image. If you use the Minimal installation option, the clip art may be listed but represented by a standard icon instead of a thumbnail image. To gain access to the clip art, right-click the standard icon, and then insert the appropriate CD.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

281915 PIP: Missing Contents of Left Pane, Missing Graphics in Project, or "Invalid Page Fault" Error Message

886568 Your CD or DVD drive does not work as expected after you remove Digital Image Suite 10


Modification Type:MajorLast Reviewed:3/27/2006
Keywords:kberrmsg kbprb KB916469