A COM client application no longer runs as expected on a Windows XP SP2-based computer, and you may receive the following error message: "E_ACCESSDENIED" (916189)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition

SYMPTOMS

On a Microsoft Windows XP Service Pack 2 (SP2)-based computer, a Component Object Model (COM) client application no longer runs as expected. Specifically, the COM client or server process is unusable. Additionally, the COM client may receive the following error message:
E_ACCESSDENIED

CAUSE

This problem occurs if the client or server process is removed from an internal table in the Rpcss.dll file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows XP SP2 installed to install this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces the hotfix in the following Microsoft Knowledge Base article:

914301 The CoCreateInstance function may return an HRESULT failure on a Windows XP Professional Service Pack 2-based or Windows Server 2003-based computer

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.1.2600.2863582,14408-Mar-200606:12x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB916189 kbAudITPRO