The File Server Resource Manager on a Windows Server 2003 R2-based computer does not send e-mail notifications to the SMTP server (914678)



The information in this article applies to:

  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition


SYMPTOMS

You may experience the following issues with the File Server Resource Manager on a Microsoft Windows Server 2003 R2-based computer:
  • The File Server Resource Manager does not send e-mail notifications to the Simple Mail Transfer Protocol (SMTP) server when file system quotas are exceeded or when file screening violations occur. Additionally, one of the following error messages is logged in the Application event log:

    Error message 1

    Event ID: 8197
    Source: SRMSVC

    Description: File server Resource Manager Service Error: Unexpected error.

    Operation:
    Running email action.
    Quota threshold reached.
    Processing File Server Resource Manager Event.

    Error-Specific details:
    Error: IMessage::Send, 0x80040211

    Error message 2

    Event ID: 8197
    Source: SRMSVC

    Description: File server Resource Manager Service Error: Unexpected error.

    Operation:
    Running email action.
    Handling a file screen audit event.
    Processing File Server Resource Manager Event.

    Error-Specific details:
    Error: IMessage::Send, 0x80040211

    Error message 3

    Event ID: 8197
    Source: SRMSVC

    Description: File server Resource Manager Service Error: Unexpected error.

    Operation:
    Running email action.
    Quota limit reached.
    Processing File Server Resource Manager Event.

    Error-Specific details:
    Error: IMessage::Send, 0x80040211
  • File Server Resource Manager does not send e-mail reports to the SMTP server. Additionally, the following error message is logged in the Application event log:
    Event ID: 150
    Source: SRMREPORTS

    Description:
    Error sending the report by email. Verify the SMTP Server settings.

    Context:
    -
    Error-specific information:
    = The message could not be sent to the SMTP server. The transport error code was 0x80040217. The server response was not available
You can successfully send e-mail notifications from the File Server Resource Manager snap-in in Microsoft Management Console (MMC).

CAUSE

This problem may occur if you are using Basic authentication together with NTLM or together with anonymous authentication on the SMTP server.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Windows Server 2003 R2 to install this hotfix.

Restart requirement

You do not have to restart the computer after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003 R2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Srmreports.dll5.2.3790.2636303,10413-Feb-200617:58x86SP1SP1QFE
Srmsvc.dll5.2.3790.26361,592,83213-Feb-200617:58x86SP1SP1QFE
Windows Server 2003 R2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Srmreports.dll5.2.3790.2636303,10414-Mar-200604:45x86SP1SP1QFE
Srmsvc.dll5.2.3790.26363,379,20014-Mar-200604:45x64SP1SP1QFE

WORKAROUND

To work around this problem, disable Basic authentication on the SMTP server.

Note Perform this procedure on a SMTP server only if the following conditions are true:
  • The SMTP server has Basic authentication enabled.
  • Basic authentication is not used by clients that submit e-mail messages.
For example, to disable Basic authentication in Microsoft Exchange Server 2003, follow these steps:
  1. In Exchange System Manager, expand Servers, expand the inbound Exchange server, expand Protocols, and then expand SMTP.
  2. Right-click the inbound SMTP virtual server, and then click Properties.
  3. Click the Access tab, and then click Authentication.
  4. Click to clear the Basic authentication check box, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

MORE INFORMATION

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:3/20/2006
Keywords:kbQFE kbExpertiseAdvanced kbHotfixServer KB914678 kbAudITPRO