WMI causes object access failure events when an SACL is applied to the HKEY_USERS registry subkey in Windows Server 2003 or in Windows XP with Service Pack 2 (914463)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional

SYMPTOMS

When a system access control list (SACL) is applied to the HKEY_USERS registry subkey on a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP with Service Pack 2, Windows Management Instrumentation (WMI) causes object access failure events. Specifically, you receive a failure audit for the LocalSystem account when the LocalSystem account tries to open the HKEY_USERS\.Default registry subkey for the MAX_ALLOWED property. The service tries to access this subkey through the Svchost.exe process that is running under the LocalSystem account.

Additionally, the following event is logged in the Security log:Event Type: Failure Audit Event Source: Security Event Category: Object Access Event ID: 560 Description: Object Open: Object Server: Security Object Type: Key Object Name: \REGISTRY\USER\.DEFAULT Handle ID: - Operation ID: {0,141727} Process ID: 1352 Image File Name: C:\WINDOWS\system32\svchost.exe Primary User Name: COMPUTER$ Primary Domain: WORKGROUP Primary Logon ID: (0x0,0x3E7) Client User Name: COMPUTER$ Client Domain: WORKGROUP Client Logon ID: (0x0,0x3E7) Accesses: MAX_ALLOWED Privileges: - Restricted Sid Count: 0

CAUSE

This problem occurs because of a bug in the Wbemcore.dll file.

RESOLUTION

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesYou must have Windows Server 2003 Service Pack 1 (SP1) installed to apply this hotfix.Restart requirementYou must restart your computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Wbemcore.dll5.2.3790.2670510,46429-Mar-200620:22x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Wbemcore.dll5.2.3790.26701,282,56029-Mar-200604:46x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Wbemcore.dll5.2.3790.26702,039,29629-Mar-200604:46IA-64

Windows XP with Service Pack 2

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesTo apply this hotfix, you must have Windows XP Service Pack 2 installed.Restart requirementYou must restart your computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Wbemcore.dll5.1.2600.2979531,45622-Aug-200612:27x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terms that are used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:9/22/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB914463 kbAudITPRO