The CoCreateInstance function may return an HRESULT failure on a Windows XP Professional Service Pack 2-based or Windows Server 2003-based computer (914301)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition

SYMPTOMS

The CoCreateInstance function may return an HRESULT failure on a Microsoft Windows XP Professional Service Pack 2 (SP2)-based or Microsoft Windows Server 2003-based computer. The CoCreateInstance function may return one of the following HRESULT values:
  • E_HANDLE
  • E_NOINTERFACE
  • E_ACCESSDENIED

CAUSE

This problem may occur if a remote procedure call (RPC) communication thread that is used for DCOM cross-process communication is ended prematurely on the computer.

For example, this problem may occur in the following scenario:
  • A DCOM client thread has an outstanding call to a DCOM server.
  • The client process closes before the threads can correctly clean up and call the CoUninitialize function.
In this scenario, another unrelated DCOM process may be prematurely and incorrectly cleaned up by the Remote Procedure Call service. Therefore, E_HANDLE, E_NOINTERFACE, or E_ACCESSDENIED errors occur in the calls that then try to use that DCOM process. When these errors occur, the DCOM server may continue to run on the computer. However, the DCOM server is now inaccessible by other DCOM processes.

RESOLUTION

Windows XP Professional SP2 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previous hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.1.2600.2859582,14402-Mar-200603:55x86

Windows Server 2003 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previous hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, 32-bit versions

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.3741,193,98421-Jul-200503:12x86NoneRTMQFE
Rpcproxy.dll5.2.3790.14126,11216-Mar-200403:17x86NoneRTMQFE
Rpcrt4.dll5.2.3790.521589,82419-Apr-200609:48x86NoneRTMQFE
Rpcss.dll5.2.3790.374296,96021-Jul-200503:12x86NoneRTMQFE
Rpcrt4.dll5.2.3790.2685645,63219-Apr-200610:22x86SP1SP1QFE

Windows Server 2003, Itanium-based versions

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.3743,582,97619-Apr-200610:58IA-64NoneRTMQFE
Rpcproxy.dll5.2.3790.14173,21619-Apr-200610:58IA-64NoneRTMQFE
Rpcrt4.dll5.2.3790.5212,151,42419-Apr-200610:58IA-64NoneRTMQFE
Rpcss.dll5.2.3790.374694,27219-Apr-200610:58IA-64NoneRTMQFE
Wole32.dll5.2.3790.3741,193,98419-Apr-200610:58x86NoneWOW
Wrpcproxy.dll5.2.3790.14126,11219-Apr-200610:58x86NoneWOW
Wrpcrt4.dll5.2.3790.521544,76819-Apr-200610:58x86NoneWOW
Rpcrt4.dll5.2.3790.26852,470,91219-Apr-200611:06IA-64SP1SP1QFE
Wrpcrt4.dll5.2.3790.2685628,73619-Apr-200611:06x86SP1WOW

Windows Server 2003, x64-based versions

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rpcrt4.dll5.2.3790.26851,720,83219-Apr-200611:09x64SP1SP1QFE
Wrpcrt4.dll5.2.3790.2685628,73619-Apr-200611:09x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbWinServ2003preSP2fix kbWinXPpreSP3fix kbfix kbbug kbpubtypekc KB914301 kbAudITPRO