The session redirection function does not work correctly on Windows Server 2003-based servers that have Terminal Server enabled (913948)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003 SP1

SYMPTOMS

Consider the following scenario:
  • Microsoft Windows Server 2003-based servers that have Terminal Server enabled are in Terminal Services Session Directory mode.
  • You enable the Restrict each user to one session setting.
  • You configure the Initial program setting on the terminal servers.
In this scenario, you may find that the session redirection function does not work correctly. Additionally, after one account is used to establish a Terminal Service session on one server, later sessions that are made by this same account cannot be redirected to this server from other terminal servers in same session directory.

CAUSE

This problem occurs because there is a problem in the Termsrv.dll file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1 (SP1), 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.2.3790.2634245,24807-Feb-200607:58x86
Windows Server 2003 with SP1, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.2.3790.2634363,00806-Feb-200616:27x64
Windows Server 2003 with SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.2.3790.2634696,83206-Feb-200616:29IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB913948 kbAudITPRO