Error message in the Windows Live OneCare display window: "Windows Live OneCare Firewall service could not start" (913786)



The information in this article applies to:

  • Windows Live OneCare

SYMPTOMS

When you run Microsoft Windows Live OneCare , you may experience one or more of the following problems:
  • The LiveOneCare icon in the taskbar turns red. When you position the pointer over the icon, a ToolTip appears. The text of the ToolTip is as follows:

    Windows Live OneCare (Status: At risk)

    Additionally, the notification area of the Windows Live OneCare display window is red.
  • You receive the following error message:
    Windows Live OneCare Firewall service could not start
  • The settings for the Windows Live OneCare Firewall may be unavailable.
  • If you examine the Microsoft Management Console, you see that the Microsoft Protection Service is running. However, this service is not working correctly. Additionally, some services on which the Microsoft Protection Service depends do not start.
Note If the Live OneCare icon in the taskbar turns red, but you do not experience any one of the other symptoms that appear in this list, click the following article number to view the article in the Microsoft Knowledge Base:

910659 How to troubleshoot the Windows OneCare Live firewall

CAUSE

You may experience one or more of these problems if there is an incorrect setting in the system PATH environment variable. Alternatively, you may experience one of these problems if the files that are related to Windows Management Instrumentation (WMI) are not correctly registered.

RESOLUTION

To resolve this problem, follow these steps:
  1. Click Start, click Run, type sysdm.cpl, and then click OK.
  2. Click the Advanced tab, and then click Environment Variables.
  3. In the System variables list, make sure that PATH appears.
    1. If PATH appears in the list, go to step b.

      If PATH does not appear in the list, follow these steps:
      1. Click New.
      2. In the Variable name box, type PATH.
      3. In the Variable value box, type %SystemRoot%\System32;%SystemRoot%;%SystemRoot%\System32\Wbem, and then click OK.
    2. Click PATH, and then click Edit.
    3. Make sure that the text in the Variable value box contains the following text:

      %SystemRoot%\System32;%SystemRoot%;%SystemRoot%\System32\Wbem

      If this text does not appear in the Variable value box, follow these steps:
      1. Under Variable value, click end of the current PATH environment variable.
      2. Type a semicolon, type the following PATH environment variable, and then click OK:

        %SystemRoot%\System32;%SystemRoot%;%SystemRoot%\System32\Wbem



        Note You must use a semicolon (;) to separate the old PATH environment variable and the new PATH environment variable.
  4. Click OK to close the Environment Variables dialog box, click OK to close the System Properties dialog box, and then restart the computer.
If you still experience one of the problems that are listed in the "Symptoms" section, follow these steps:
  1. Click Start, click Run, type Regsvr32 %SystemRoot%\System32\wbem\wmidcprv.dll, and then click OK.
  2. Click OK, and then restart the computer.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

910659 How to troubleshoot the Windows OneCare Live firewall


Modification Type:MinorLast Reviewed:5/25/2006
Keywords:kbprb kbtshoot KB913786 kbAudEndUser