Error message when a DAV client tries to authenticate with an Exchange Server 2003 SP1 front-end server: "HTTP 500 - Internal server error" (911971)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

Consider the following scenario. A user uses tries to access a mailbox by using a Distributed Authoring and Version (DAV) e-mail client program, such as Microsoft Outlook Web Access or Microsoft Entourage. Additionally, the following conditions are true:
  • Microsoft Exchange is configured in a front-end and back-end architecture.
  • The front-end server is running Microsoft Exchange Server 2003 Service Pack 1 (SP1) on a Microsoft Windows Server 2003-based computer.
  • The user tries to authenticate with the Exchange Server 2003 SP1 front-end server.
In this scenario, the user receives the following error message:
HTTP 500 - Internal server error
Internet Explorer
If you restart the World Wide Web Publishing service on the Exchange Server 2003 SP1 front-end server, the problem is temporarily resolved.

CAUSE

This problem occurs if Microsoft Internet Information Services (IIS) and DAV incorrectly interact. In this situation, DAV enters an unexpected state and crashes.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Microsoft Exchange Server 2003 Service Pack 2 (SP2) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Davex.dll6.5.7650.101,126,40010-Dec-200508:23x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbfix kbBug kbpubtypekc KB911971 kbAudITPRO