You may not be able to use Remote Assistance to connect to a client computer after you install Windows XP SP2 on a computer that has the Multilingual User Interface Pack (MUI) installed (911949)



The information in this article applies to:

  • Microsoft Windows XP Professional

SYMPTOMS

After you install Microsoft Windows XP Service Pack 2 (SP2) on a computer that has the Multilingual User Interface Pack (MUI) installed, you may not be able to use Remote Assistance to connect to a client computer.

CAUSE

This problem occurs because the Setup program cannot correctly configure the Distributed COM (DCOM) Launch and Access permissions for Microsoft Help and Support services. The Setup program cannot correctly configure these permissions if the computer was set to a non-English language when you installed Windows XP SP2.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The P1 version of this P2 has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Helpsvc.exe5.1.2600.2828744,44814-Jan-200606:12x86

Installation information

After you install this hotfix, you must run certain commands at a command prompt. To do this, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type cd %Windir%\PCHEALTH\HELPCTR\Binaries, and then press ENTER.

    Note In this command, %Windir% represents the drive where Windows XP is installed.
  3. Type Helpsvc /regserver, and then press ENTER.
  4. Type Helpsvc /RAUninstall, and then press ENTER.
  5. Type Helpsvc /RAInstall, and then press ENTER.

WORKAROUND

To work around this problem, install Windows XP Service Pack 2 by using a user account that has the language setting as English.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the standard terminology that is used describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbfix kbbug kbpubtypekc KB911949 kbAudEndUser kbAudITPRO