Error message in Internet Explorer when you try to access a Web site that requires Kerberos authentication on a Windows XP-based computer: "HTTP Error 401 - Unauthorized: Access is denied due to invalid credentials" (911149)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Professional

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

You are using Microsoft Internet Explorer on a Microsoft Windows XP-based computer. When you try to access a Web site that requires Kerberos authentication, you may receive the following error message:
HTTP Error 401 - Unauthorized: Access is denied due to invalid credentials.

CAUSE

This problem may occur if the Web site uses a CNAME resource record in the Domain Name System (DNS) to contact the server that initiates Kerberos authentication. (This server also issues the Kerberos ticket.) When you use Internet Explorer to access the Web site, Internet Explorer uses the host name of the server instead of the CNAME resource record to contact the server. The authentication process does not work because only the Service Principal Name (SPN) for the CNAME resource record is registered on the account that is used for the authentication.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirement
Wininet.dll6.0.2800.1545587,26406-Apr-200609:42x86SP1
Wininet.dll6.0.2900.2882663,55207-Apr-200604:33x86SP2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you apply software update 911149, follow these steps to enable this update:
  1. Exit Internet Explorer.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main

  4. On the Edit menu, point to New, and then click Key.
  5. Type FeatureControl, and then press ENTER.
  6. With the FeatureControl registry subkey that you created in step 5 selected, point to New on the Edit menu, and then click Key.
  7. Type FEATURE_USE_CNAME_FOR_SPN_KB911149, and then press ENTER.
  8. With the FEATURE_USE_CNAME_FOR_SPN_KB911149 registry subkey selected that you created in step 7, point to New on the Edit menu, and then click DWORD Value.
  9. Type Iexplore.exe, and then press ENTER.
  10. Right-click Iexplore.exe, and then click Modify.
  11. In the Value data box, type 1, and then click OK.

    Note To revert to the previous behavior for backward compatibility, reset this value to 0x0.
  12. Exit Registry Editor.
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

326985 How to troubleshoot Kerberos-related issues in IIS

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbWinXPsp2fix kbWinXPsp1fix kbBug kbfix kbQFE kbpubtypekc KB911149 kbAudITPRO