The allotment type from a contract template is not used when you create a contract in Microsoft CRM 3.0 (909284)



The information in this article applies to:

  • Microsoft CRM 3.0

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

When you create a contract in Microsoft Dynamics CRM 3.0, the allotment type from the corresponding contract template is not used. If you view the contract in the Microsoft CRM database, you see that the AllotmentTypeCode value is set to 1. This value is set regardless of the AllotmentTypeCode value that is specified in the contract template.

This problem occurs if you create a contract in an account or in a contact. This problem does not occur if you create a contract by locating the contract template in Service in Microsoft CRM 3.0.

CAUSE

This problem occurs because Microsoft CRM 3.0 does not decrement the time for a contract line if the contract is created without using Service.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next version of Microsoft CRM that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this update on all computers that are running Microsoft CRM 3.0 Server. Additionally, install this update on all computers that are running Microsoft CRM client for Microsoft Office Outlook.

Prerequisites

To install this update, you must have installed Microsoft CRM 3.0.

Removal information

To remove this hotfix from a computer that is running one of the following operating systems, use the Add or Remove Programs item in Control Panel:
  • Microsoft Windows Server 2003
  • Microsoft Windows XP
  • Microsoft Windows 2000
If you are an administrator, you can use the Spunist.exe tool to remove this hotfix from a computer that is running Windows Server 2003, Windows XP, or Windows 2000. The Spuninst.exe utility is located in the %Windir%\$NTUninstallKB909284$\Spuninst folder.

For more information about the package installer parameters, click the following article number to view the article in the Microsoft Knowledge Base:

832475 Description of the new features in the package installer for Windows software updates

Restart requirement

If you are prompted, restart the computer after you install the hotfix. You must restart Microsoft CRM client for Outlook if Outlook was open when you installed this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Server

File nameFile versionFile sizeDateTimePlatform
Crmobjectmodel.dll3.0.5300.10716,732,04025-Feb-200608:19x86
Microsoft.crm.application.c3.0.5300.1078408,34409-Mar-200622:18x86

Client

File nameFile versionFile sizeDateTimePlatform
Crmobjectmodel.dll3.0.5300.10786,732,04809-Mar-200622:17x86
Microsoft.crm.application.c3.0.5300.1078408,34409-Mar-200622:18x86

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft product updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards

Steps to reproduce the problem

  1. Log on to the Microsoft CRM Web application.
  2. Create a new contract template. In this template, set the allotment type to Time, and then save the contract template.
  3. Create a new record for an account. In this record, create a contract. To do this, click Contracts on the Details menu.
  4. Create a new line in the contract that defines the following settings:
    • Total Cases/Minutes: 60
    • Total Price: 90
  5. Save the contract and then create an invoice for this contract.
  6. Create a new case for the account that you used in step 3. Select the contract line that you created in step 4, and then save the case.
  7. Create a new service activity for the case that you created in step 6. Set the time for this service activity to 60 minutes.
  8. Save the service activity, and then close the service activity so that it has the Completed status.
  9. Resolve the case that you created in step 6, and then set the Billable time value to 60 minutes. This setting matches the time for the service activity that you created in step 7.
  10. Open the contract line that you created in step 4 and view the value that appears in the Allotments Used field.
This value is set to 1 and not to 60 minutes as expected.

Modification Type:MinorLast Reviewed:9/13/2006
Keywords:kbMBSworkflow kbHotfixServer kbQFE kbMBSMigrate kbpubtypekc KB909284 kbAudKnowledgeWorker kbAudEndUser