Error message when you try to migrate data from QuickBooks to Small Business Accounting: "The selected file is not valid You must select another file" (908989)



The information in this article applies to:

  • Microsoft Office Small Business Accounting 2006
  • Microsoft Office Small Business Management Edition 2006

SYMPTOMS

You are migrating data from QuickBooks to Microsoft Office Small Business Accounting. After you select a QuickBooks company file, you may receive the following error message:
The selected file is not valid. You must select another file.

CAUSE

This problem occurs when one of the following conditions is true:
  • You are migrating an unsupported version of QuickBooks.
  • You are importing an unsupported file type.
  • The .qbw file that you try to migrate contains damaged transactions or errors that conflict with the migration.

RESOLUTION

To resolve this problem, use the following three methods in the order in which they are presented.

Method 1: Verify that you have the most recent updates

  1. Verify you are using a supported version of QuickBooks. Small Business Accounting supports the following versions of QuickBooks:
    • For importing Master Records only:
      • QuickBooks Basic 2002
      • QuickBooks pro 2002
      • QuickBooks Premier 2002
      • QuickBooks Enterprise 2002
      • QuickBooks Accountant 2002
      • QuickBooks Basic 2003
      • QuickBooks pro 2003
      • QuickBooks Premier 2003
      • QuickBooks Enterprise 2003
      • QuickBooks Accountant 2003
      • QuickBooks Basic 2004
      • QuickBooks pro 2004
      • QuickBooks Premier 2004
      • QuickBooks Enterprise 2004
      • QuickBooks Accountant 2004
      • QuickBooks Basic 2005
      • QuickBooks pro 2005
      • QuickBooks Premier 2005
      • QuickBooks Enterprise 2005
      • QuickBooks Accountant 2005
    • For importing all data (records and transactions):
      • QuickBooks pro 2004
      • QuickBooks Premier 2004
      • QuickBooks Enterprise 2004
      • QuickBooks Accountant 2004
      • QuickBooks pro 2005
      • QuickBooks Premier 2005
      • QuickBooks Enterprise 2005
      • QuickBooks Accountant 2005
  2. Download the following items.
    1. Download Service Pack 1 for Business Contact Manager Update and Small Business Accounting. To do this, visit the following Microsoft Web site:
    2. Download the QuickBooks transaction migration update. To do this, visit the following Microsoft Web site:

Method 2: Verify that you are using the correct file name extension

Verify that the file name extension of the QuickBooks company file that you try to migrate is .qbw. If the file name extensions are not displayed when you view the QuickBooks company file, follow these steps:
  1. Right-click Start, and then click Explore.
  2. On the Tools menu, click Folder Options.
  3. In the Folder Options dialog box, click the View tab.
  4. In the Advanced Settings pane, click to clear the Hide extensions for known file types option.
  5. Click Apply.

Method 3: Rebuild the QuickBooks company file

If you have verified that you have all the most recent updates and that you are using a supported version and file type, the likely problem is that the QuickBooks company data is damaged. To correct this problem, you must run the Rebuild Data utility in QuickBooks. To do this, follow these steps:
  1. In QuickBooks, open the company that you want.
  2. On the Window menu, click Close All.
  3. On the File menu, point to Utilities, and then click Rebuild Data.
  4. Click OK when you are prompted to make a backup.

    Note Rebuilding requires that you back up your company file.
  5. Click No if you are prompted with the question of whether you want to replace the backup file. To avoid overwriting your current file, type a new name in the Filename field.

    Note Do not replace your current backup. Instead, use other media for this backup, or back up to the hard disk.
  6. In the Back up Company File window, click Back Up.
  7. The Rebuild Data utility will start as soon as the backup is completed. Click OK when you receive a message that states that the rebuild has been completed.
  8. Close your company data file, and then reopen it to update the lists in the file:
    1. On the File menu, click Close Company.
    2. On the File menu, click Open Company.
    3. Select the company that you want to open, and then click Open.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:12/12/2005
Keywords:kbtshoot kbMBSMigrate kbprb KB908989 kbAudEndUser kbAudKnowledgeWorker