Stop error message on an Exchange Server 2003 server: "INVALID_PROCESS_ATTACH_ATTEMPT (5)" (908674)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

On a server that is running Microsoft Exchange Server 2003, you receive a stop error message that resembles the following:
INVALID_PROCESS_ATTACH_ATTEMPT (5) Arguments: Arg1: fdd95978 Arg2: ff2a6d88 Arg3: 00000001 Arg4: 00000000

CAUSE

This problem occurs because the operation system crashes. When the Store.exe process or the Inetinfo.exe process is under a heavy load, the Exchange Installable File System (ExIFS) driver causes the process to crash. Additionally, the crashed Store.exe process or the crashed Inetinfo.exe process causes the operating system to crash.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Microsoft Exchange Server 2003 Service Pack 2 (SP2) installed to apply this hotfix. For more information about how to obtain the latest service pack for Exchange Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

After you apply this hotfix, the following services and drivers must be restarted:
  • ExIFS driver
  • Microsoft Exchange System Attendant
  • IIS Admin Service and all dependent services

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

When you apply this hotfix, you will be prompted to refer to article 246216 in the Microsoft Knowledge Base. You are prompted to view the article because the ExIFS driver must be unloaded to apply this hotfix. To confirm that the ExIFS driver is successfully reloaded, you can view event ID 9216 in the System log. If the ExIFS driver is not automatically reloaded, refer the following article in the Microsoft Knowledge Base for information about how to manually reload the ExIFS driver:

246216 Exchange 2000 Server or Exchange Server 2003 ExIFS may not start after ExIFS is manually stopped


Modification Type:MajorLast Reviewed:9/28/2006
Keywords:kbfix kbBug kbexchIFS kbQFE kbhotfixserver kbpubtypekc KB908674 kbAudITPRO