Office Outlook 2003 may stop responding on a computer that is running Windows Server 2003 or Windows XP because of a problem in the RPC engine (908521)



The information in this article applies to:

  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition

SYMPTOMS

You are using the following products together:
  • Microsoft Office Outlook 2003 or a later version of Outlook
  • Microsoft Exchange
  • Microsoft Windows XP with Service Pack 2 (SP2) or Microsoft Windows Server 2003
In this configuration, you may experience one or more of the following symptoms:
  • Network outages and connectivity issues cause the Outlook client to stop responding. You may have to restart the Outlook client to resume the full range of expected functions.

    Note The network outages and connectivity issues are similar to issues that you may experience in wireless scenarios.
  • The Outlook client stops responding if you are connecting to an Exchange server by using Connect to my mail box using HTTP functionality. This scenario is common if you are connecting to an Exchange server over the Internet.
  • The Exchange server stops responding when the Exchange server handles client requests from Outlook 2003 or from a later version of Outlook. You may have to restart the Exchange server to resume the full range of expected functions.
In Windows XP with SP2 or in Windows Server 2003 with Service Pack 1 (SP1), you may also experience remote procedure call (RPC) engine reliability issues in applications that use asynchronous RPC and RPC over HTTP functionality. The symptoms of RPC engine reliability issues may include the following:
  • Client applications receive error messages that report unhandled access violation exceptions.
  • Client applications that use RPC stop responding.
Additionally, when you use the DSFR service in Microsoft Windows Server 2003 R2, you may experience one or more of the following symptoms:
  • The DFSR service stops responding. You may have to restart the DFSR service to resume the full range of expected functions.
  • The DFSR service does not replicate DFS root data. You may have to restart the DFSR service to resume the full range of expected functions.

CAUSE

These problems occur because of a problem in the RPC engine (Rpcrt4.dll).

RESOLUTION

Windows Server 2003

Update information

The following files are available for download from the Microsoft Download Center:


Windows Server 2003, x86-based versions
DownloadDownload the 908521 package now.

Windows Server 2003, Itanium-based versions
DownloadDownload the 908521 package now.

Windows Server 2003, x64-based versions
DownloadDownload the 908521 package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file. Prerequisites To apply this update on x86-based and Itanium-based versions of Windows Server 2003, you must have Windows Server 2003 SP1 installed on the computer.Restart requirementYou must restart the computer after you apply this update.Update replacement informationThis update does not replace any other updates.File information The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rpcrt4.dll5.2.3790.2568642,56010-Nov-200519:52x86SP1SP1GDR
Rpcrt4.dll5.2.3790.2568642,56010-Nov-200520:01x86SP1SP1QFE

Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rpcrt4.dll5.2.3790.25682,459,13610-Nov-200520:22IA-64SP1SP1GDR
Wrpcrt4.dll5.2.3790.2568626,17610-Nov-200520:22x86SP1WOW
Rpcrt4.dll5.2.3790.25682,459,64810-Nov-200520:22IA-64SP1SP1QFE
Wrpcrt4.dll5.2.3790.2568626,17610-Nov-200520:22x86SP1WOW

Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rpcrt4.dll5.2.3790.25681,716,73610-Nov-200520:01x64SP1SP1GDR
Wrpcrt4.dll5.2.3790.2568626,17610-Nov-200520:22x86SP1WOW
Rpcrt4.dll5.2.3790.25681,717,24810-Nov-200520:22x64SP1SP1QFE
Wrpcrt4.dll5.2.3790.2568626,17610-Nov-200520:22x86SP1WOW

Windows XP

Update information

The following files are available for download from the Microsoft Download Center:


Windows XP with SP2
DownloadDownload the 908521 package now.

Windows XP Professional x64 Edition
DownloadDownload the 908521 package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file. Prerequisites To apply this update on x86-based versions of Windows XP, you must have Windows XP SP2 installed on the computer.Restart requirementYou must restart the computer after you apply this update.Update replacement informationThis update does not replace any other updates.File information The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP with SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rpcrt4.dll5.1.2600.2794581,63210-Nov-200519:22x86SP2SP2GDR
Rpcrt4.dll5.1.2600.2794582,14410-Nov-200519:20x86SP2SP2QFE

Windows XP Professional x64 Edition
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rpcrt4.dll5.2.3790.25681,716,73610-Nov-200520:01x64SP1SP1GDR
Wrpcrt4.dll5.2.3790.2568626,17610-Nov-200520:22x86SP1WOW
Rpcrt4.dll5.2.3790.25681,717,24810-Nov-200520:22x64SP1SP1QFE
Wrpcrt4.dll5.2.3790.2568626,17610-Nov-200520:22x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbWinServ2003SP1fix kbWinXPpreSP3fix kbBug kbfix kbpubtypekc KB908521 kbAudITPRO kbAudEndUser