A cluster does not fail over replicated cluster disks after you install Windows Server 2003 SP1 or an x64-based version of Windows Server 2003 (908510)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition

SYMPTOMS

After you install Microsoft Windows Server 2003 Service Pack 1 (SP1) or an x64-based version of Microsoft Windows Server 2003 on a server cluster, the cluster does not fail over replicated cluster disks or non-replicated cluster disks that do not support the Disk Unique ID feature.

CAUSE

This problem occurs because the disks in a geographically dispersed cluster have been renumbered. When these disks are renumbered, they no longer match their disk signatures or the cache of known disks.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 SP1 installed on the computer.

Note Service Pack 1 is included in x64-based versions of Windows Server 2003.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, 32-bit versions
   Date         Time   Version          Size  File name
   -------------------------------------------------------
   01-Oct-2005  00:36  5.2.3790.2539  68,608  Clusdisk.sys
Windows Server 2003, 64-bit Itanium-based versions
   Date         Time   Version           Size  File name
   --------------------------------------------------------
   01-Oct-2005  01:53  5.2.3790.2539  212,992  Clusdisk.sys
Windows Server 2003, 64-bit x64-based versions
   Date         Time   Version           Size  File name
   --------------------------------------------------------
   01-Oct-2005  01:53  5.2.3790.2539  112,128  Clusdisk.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbQFE kbHotfixServer kbpubtypekc KB908510 kbAudITPRO