Internet Explorer 6 cannot use the Kerberos authentication protocol to connect to a Web server that uses a non-standard port on Windows XP or Windows Server 2003 (908209)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Web Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

Consider the following scenario:
  • You have a Microsoft Windows XP-based computer or a Microsoft Windows Server 2003-based computer that is running Internet Information Services (IIS).
  • You have two Web servers that have different ports and identities. These two Web servers are running on the same computer. For example, Web server 1 runs on port 80 under identity "id1" and Web server 2 runs on port 81 under identity "id2".
  • Both the Web servers use Kerberos authentication protocol version 5.
  • You use the Setspn utility to declare the Service Principal Name (SPN) for Web server 2.
  • You use the same host name to connect to Web server 1 and to Web server 2. You use Microsoft Internet Explorer 6 to make this connection.

    For example, you use http://examplewebserver to connect to Web server 1 and http://examplewebserver:81 to connect to Web server 2. In this example, you use the same examplewebserver host name to connect to both Web servers.
In this scenario, Internet Explorer 6 can use the Kerberos protocol to connect to Web server 1. However, Internet Explorer 6 cannot use the Kerberos protocol to connect to Web server 2.

CAUSE

This problem occurs because the Wininet.dll file does not pass the port number of the target Web server when it calls the InitializeSecurityContext function to build the Kerberos ticket. This prevents Internet Explorer 6 from using the Kerberos protocol to connect to multiple Web servers that run on different ports under different identities.

RESOLUTION

Hotfix information

Microsoft Windows XP

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesNo prerequisites are required.Restart requirementYou must restart your computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Wininet.dll6.0.2900.2905664,06410-May-200614:35x86

Microsoft Windows Server 2003

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesNo prerequisites are required.Restart requirementYou must restart your computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wininet.dll6.0.3790.26991,703,93610-May-200605:48IA-64SP1SP1QFE
Wwininet.dll6.0.3790.2699665,60010-May-200605:48x86SP1WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wininet.dll6.0.3790.26991,189,88810-May-200605:48x64SP1SP1QFE
Wwininet.dll6.0.3790.2699665,60010-May-200605:48x86SP1WOW
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Wininet.dll6.0.3790.2699665,60010-May-200607:41x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Post-hotfix installation instructions

After you install the hotfix, you must add the FEATURE_INCLUDE_PORT_IN_SPN_KB908209 registry key, and then set its DWORD value to iexplore.exe. To do this, follow these steps.

For 32-bit computers

  1. Click Start, click Run, type regedit, and then click OK.
  2. In the left pane, locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl

  3. On the Edit menu, point to New, and then click Key.
  4. Type FEATURE_INCLUDE_PORT_IN_SPN_KB908209, and then press ENTER.
  5. On the Edit menu, point to New, and then click DWORD Value.
  6. Type iexplore.exe, and then press ENTER.
  7. On the Edit menu, click Modify.
  8. Type 1 in the Value data box, and then click OK.
  9. Exit Registry Editor.

For 64-bit computers

  1. Click Start, click Run, type regedit, and then click OK.
  2. In the left pane, locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\Main\FeatureControl

  3. On the Edit menu, point to New, and then click Key.
  4. Type FEATURE_INCLUDE_PORT_IN_SPN_KB908209, and then press ENTER.
  5. On the Edit menu, point to New, and then click DWORD Value.
  6. Type iexplore.exe, and then press ENTER.
  7. On the Edit menu, click Modify.
  8. Type 1 in the Value data box, and then click OK.
  9. Exit Registry Editor.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/21/2006
Keywords:kbWinXPsp3fix kbWinXPpreSP3fix kbWinServ2003preSP2fix kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB908209 kbAudITPRO