You cannot install a printer on a cluster node to a Windows Server 2003 cluster (906752)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition

SYMPTOMS

When you try to use the Add Printer Wizard to add more printers to a virtual server that is part of a Microsoft Windows Server 2003 cluster, you may receive an error message after the Add Printer Wizard is completed. The error message that you may receive is similar to the following:
Unable to install Printer. The Print Processor does not exist.
Therefore, you cannot add the printer to the Windows Server 2003 cluster. This problem occurs even though you have installed the hotfix installed that is described in the following article in the Microsoft Knowledge Base:

835609 You receive an error message when you try to use the Add Printer Wizard to add a printer to a virtual server that is part of a Windows Server 2003 cluster

CAUSE

This problem occurs because the print driver uses a custom print processor.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Windows Server 2003 SP1 to install this hotfix.

Note x64-based versions of Windows Server 2003 do not require service pack 1 to install this hotfix.

Note This hotfix may delete all printer IP ports that are on the computer. You may want to back up the port configuration before you install this hotfix.

Restart requirement

After you install this hotfix, you must restart the server.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, x86-based versions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   07-Sep-2005  02:30  5.2.3790.2524     348,160  Localspl.dll     
   07-Sep-2005  02:30  5.2.3790.2524      99,840  Ntprint.dll      
 
Windows Server 2003, x64-based versions

   Date         Time   Version            Size    File name    Platform
   --------------------------------------------------------------------
   07-Sep-2005  14:24  5.2.3790.2524     749,568  Localspl.dll     x64
   07-Sep-2005  14:24  5.2.3790.2524     158,720  Ntprint.dll      x64
   07-Sep-2005  14:24  5.2.3790.2524      99,840  Wntprint.dll     x86

Windows Server 2003, Itanium-based versions

   Date         Time   Version            Size    File name    Platform
   --------------------------------------------------------------------
   07-Sep-2005  14:23  5.2.3790.2524     968,192  Localspl.dll     IA-64
   07-Sep-2005  14:23  5.2.3790.2524     275,456  Ntprint.dll      IA-64
   07-Sep-2005  14:23  5.2.3790.2524      99,840  Wntprint.dll     x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/14/2006
Keywords:kbHotfixServer kbQFE KB906752 kbAudITPRO