When you use Internet Explorer on a Windows XP-based computer, Internet Explorer may take 8 to 11 seconds to open a Web page (906650)



The information in this article applies to:

  • Microsoft Windows XP Professional

SYMPTOMS

When you use Microsoft Internet Explorer on a Microsoft Windows XP-based computer, Internet Explorer may take 8 to 11 seconds to open a Web page on the first try. This delay does not occur on subsequent tries.

Note This problem may occur when you use Internet Explorer together with the Web Proxy Automatic Discovery (WPAD) feature.

CAUSE

When the DHCP Client service code first runs, it does not correctly process the Dynamic Host Configuration Protocol (DHCP) inform messages that are used by the WPAD feature. The WPAD feature uses the DHCP inform messages to retrieve information from a DHCP server. Therefore, Internet Explorer is slow the first time it opens a Web page that uses the WPAD feature. Subsequent delays do not occur because the information is retrieved and cached for later use.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart the DHCP Client service after you apply this hotfix. Also, make sure to stop the DHCP Client service before you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Dhcpcsvc.dll5.1.2600.2794111,10411-Nov-200502:43x86

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbWinXPpreSP3fix kbBug kbfix kbpubtypekc KB906650 kbAudEndUser kbAudITPRO