Recipients in European countries cannot read e-mail messages that you send by using Microsoft CRM or by using Microsoft CRM Sales for Outlook (906172)



The information in this article applies to:

  • Microsoft Business Solutions CRM Sales for Outlook, when used with:
    • Microsoft CRM 1.2
  • Microsoft CRM 1.2

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you send e-mail messages by using the Microsoft CRM 1.2 or by using Microsoft CRM Sales for Outlook (the Outlook client), unrecognizable characters may appear in the body of the e-mail messages.

You typically experience this problem when you send e-mail messages to recipients who are in a European country, such as Germany.

CAUSE

This problem occurs because when you send e-mail messages by using Microsoft CRM 1.2 or by using the Outlook client, the outgoing e-mail messages are encoded with the default code page of UTF-8. In some countries, a different code page is used. Additionally, some Internet Service Providers (ISPs) do not support UTF-8 encoded e-mail messages. Therefore, e-mail messages do not appear correctly if the messages contain extended characters, such as letters that have an umlaut. Instead, the extended characters appear as unrecognizable characters.

In some European countries, such as Germany, one of the following Western European code pages is typically used:
  • ISO-8859-1
  • ISO-8859-15

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Microsoft CRM has a fix for this problem that is part of a cumulative update. The cumulative update information is described in the following article in the Microsoft Knowledge Base:

904435 Update Rollup 2 is available for Microsoft CRM 1.2

Install this update on computers that are running the Microsoft CRM 1.2 version of Microsoft CRM-Exchange E-mail Router.

To help prevent data from being truncated after you apply this update, you must set the Microsoft CRM field length according to the codepage that you use. To set this field length, follow these steps:
  1. Open Registry Editor. To open the program, click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

  3. Right-click MSCRM, point to New, and then click String Value.
  4. Type SMTPCodePage, and then press ENTER.
  5. Right-click SMTPCodePage, and then click Modify.
  6. In the Value data box, type one of the following values according to the code page that you use:
    • big5
    • euc-jp
    • euc-kr
    • gb2312
    • iso-2022-jp
    • iso-2022-kr
    • iso-8859-1
    • iso-8859-2
    • iso-8859-3
    • iso-8859-4
    • iso-8859-5
    • iso-8859-6
    • iso-8859-7
    • iso-8859-8
    • iso-8859-9
    • iso-8859-15
    • koi8-r
    • shift-jis
    • us-ascii
    • utf-7
    • utf-8
  7. Click OK, and then exit Registry Editor.
Note This registry key is also valid if you are using Microsoft Dynamics CRM 3.0.

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft product updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards

For more information about problems receiving a reply from an AOL e-mail client in Microsoft CRM, click the following article number to view the article in the Microsoft Knowledge Base:

892516 An e-mail message does not cause a corresponding Microsoft CRM e-mail activity to be created when you receive a reply from an AOL e-mail client


Modification Type:MinorLast Reviewed:9/8/2006
Keywords:kbMBSMigrate kbQFE kbHotfixServer kbpubtypekc KB906172 kbAudDeveloper