FIX: Rules may not be executed when the current state is expected to have a start state or a target in Connected Services Framework Server 2.5 AL Service Logic (906160)



The information in this article applies to:

  • Connected Services Framework

SYMPTOMS

In Microsoft Connected Services Framework Server 2.5 AL Service Logic, rules may not be executed when the current state is expected to have a start state or a target.

CAUSE

This problem may occur because the MID data structure is not set correctly. The current state of the MID data structure is always set to the "VASID.Action.EndState" string. This is true even though the previous rule sets the next state as the "VASID.Action.EndState-StartState" string or the "VASID.Action.EndState-StartState-Target" string. This problem occurs because of a mismatch in the strings.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Host Integration Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, we recommend that you follow these steps when you apply this hotfix:
  1. Use the Microsoft BizTalk Server Health and Activity Tracking (HAT) tool to verify that no orchestrations are running.
  2. Undeploy the following Service Logic .dll files and any files that depend on these Service Logic .dll files:
    • Microsoft.Csf.Sbe.OrderHandling.ServiceLogic.dll
    • Microsoft.Csf.Sbe.OrderHandling.ServiceLogic.Orchestration.dll
    • Microsoft.Csf.Sbe.OrderHandling.ServiceLogic.Schema.dll
  3. Deploy the following Service Logic .dll files from this hotfix:
    • Microsoft.Csf.Sbe.OrderHandling.ServiceLogic.dll
    • Microsoft.Csf.Sbe.OrderHandling.ServiceLogic.Orchestration.dll
    • Microsoft.Csf.Sbe.OrderHandling.ServiceLogic.Schema.dll

Hotfix replacement information

This hotfix is not replaced by any later hotfix.

Registry information

You do not have to create or modify any registry keys to enable this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Microsoft Windows Server 2003
   Date         Time   Version     Size       File name
   ---------------------------------------------------------------------------------------------------------
   12-Aug-2005  19:21  2.5.0.1061     40,960  Microsoft.csf.sbe.orderhandling.servicelogic.dll  
   12-Aug-2005  19:21  2.5.0.1061  1,282,048  Microsoft.csf.sbe.orderhandling.servicelogic.orchestration.dll  
   12-Aug-2005  19:21  2.5.0.1061    364,544  Microsoft.csf.sbe.orderhandling.servicelogic.schema.dll
Note This hotfix contains only those files that you must have to correct the issues that this article lists. This hotfix may not contain all the files that you must have to fully update a product to the latest build.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:12/7/2005
Keywords:kbtshoot kbfix kbbug KB906160 kbAudITPRO kbAudDeveloper