The scan engines are not updated, and a "Could not delete zipped engine file" error is logged in the Programlog.txt file in Antigen (905975)



The information in this article applies to:

  • Sybari Antigen 8.0 for Microsoft Exchange
  • Sybari Antigen 8.0 for IM
  • Sybari Antigen 8.0 for Microsoft SharePoint Portal Server
  • Sybari Antigen 8.0 for SMTP Gateways
  • Sybari Antigen 7.5 for Microsoft Exchange
  • Sybari Antigen 7.5 for IM
  • Sybari Antigen 7.5 for Microsoft SharePoint Portal Server
  • Sybari Antigen 7.5 for SMTP Gateways

SYMPTOMS

After a scheduled scan engine update, the scan engines are not updated. Additionally, the following error is logged in the Programlog.txt file: ERROR: Could not delete zipped engine file
Scan engines are no longer updating The same error is logged in the Application log.

Note This behavior may also occur when you try to manually update a scan engine.

CAUSE

This issue occurs if one of the engine folders contains a read-only attribute. During the scan engine update, the engine folders are renamed and then deleted. However, Antigen cannot delete an engine folder if the engine folder contains a read-only attribute.

RESOLUTION

To resolve this issue, follow these steps:
  1. Start Windows Explorer, and then double-click one of the following folders as appropriate:
    • Antigen for Exchange
    • Antigen for SMTP
    • Antigen for SharePoint
    • Antigen for IM
    You will see folders for each search engine for which you are licensed. For example, you may see the following folders:
    • CAIis
    • CAVet
    • Sophos
  2. Double-click each folder that generates the error. You will see the following folders:
    • Engine _name
    • Engine _nameNew
    • Engine_nameOld
    • UpdateBin
  3. Delete the Engine_nameOld folder.
  4. Rename the Engine _name folder to "Engine_nameOld".
  5. Rename the Engine _nameNew folder to "Engine_name".

    Note If you cannot delete or rename the folders, stop the Antigen services to release any folders that are currently being used. You may also have to stop the Microsoft Exchange Server services.
  6. Start the Sybari Client (SybariClient.exe).
  7. In Shuttle Navigator, click Settings, and then click Scanner Updates.
  8. Click each search engine for which you renamed the folders, and then click Update Now.
  9. Monitor the next scheduled engine update to confirm that the scan engines are updated.

Modification Type:MajorLast Reviewed:10/5/2005
Keywords:kbtshoot KB905975