A Windows Server 2003-based terminal server in a forest cannot obtain a license from a license server in a different forest (905687)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition

SYMPTOMS

A Microsoft Windows Server 2003-based server that has Terminal Server enabled and that is located in a forest cannot obtain a license from a Terminal Server license server that is located in a different forest when those forests are connected by an external trust.

Note External trusts only support NTLM authentication. External trusts are also known as "down-level trusts" or "Microsoft Windows NT Server 4.0 trusts."

CAUSE

This problem occurs because Terminal Server cannot obtain a license when NTLM is used for authentication.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, 32-bit x86-based versions
File nameFile versionFile sizeDateTimePlatform
Mstlsapi.dll5.2.3790.385106,49610-Aug-200503:02x86

Windows Server 2003, 32-bit x86-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Mstlsapi.dll5.2.3790.2505118,27210-Aug-200503:13x86

Windows Server 2003, 64-bit Itanium-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Mstlsapi.dll5.2.3790.385316,41609-Aug-200513:09IA-64Not Applicable
Wmstlsapi.dll5.2.3790.385106,49609-Aug-200513:09x86WOW

Windows Server 2003, 64-bit Itanium-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mstlsapi.dll5.2.3790.2505347,64809-Aug-200513:09IA-64SP1Not Applicable
Wmstlsapi.dll5.2.3790.2505118,27209-Aug-200513:09x86SP1WOW

Windows Server 2003, 64-bit x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mstlsapi.dll5.2.3790.2505190,97609-Aug-200513:09x64SP1Not Applicable
Wmstlsapi.dll5.2.3790.2505118,27209-Aug-200513:09x86SP1WOW

WORKAROUND

To work around this problem, use either of the following methods.

Method 1

Install a Terminal Server license server in the same domain or forest as the Terminal Server that is requesting the license.

For more information about license server roles, visit the following Microsoft Web site:For more information about where to install license servers for each role, visit the following Microsoft Web site:

Method 2

Create a forest trust that supports Kerberos authentication between the two forests.

For more information about forest trusts, visit the following Microsoft Web site:

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

279561 How to override the license server discovery process in Windows Server 2003 Terminal Services


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbHotfixServer kbQFE kbpubtypekc KB905687 kbAudITPRO kbAudDeveloper