FIX: When you create a database or a table, an error occurs and Access unexpectedly closes in Office Access 2003 or in Access 2002 (905530)



The information in this article applies to:

  • Microsoft Office Access 2003
  • Microsoft Access 2002

SYMPTOMS

When you create a database or a table in Microsoft Office Access 2003 or in Microsoft Access 2002, an error occurs in Msaccess.exe and Access unexpectedly closes. When this problem occurs, you may receive the following error message:
Access has encountered a problem and needs to close. We are sorry for the inconvenience.
If you were in the middle of something, the information you were working on might be lost.
Please tell Microsoft about this problem.
We have created an error report that you can send to help us improve Access. We will treat this report as confidential and anonymous.
To see what data this error report contains, click here.
When you view the data that the error report contains, the following error-signature information appears depending on the version of Access that you are using.
Application Name Application Version Module NameModule VersionOffset
Msaccess.exe11.0.6355.0Msaccess.exe11.0.6355.0000fb140
Msaccess.exe11.0.5614.0Msaccess.exe11.0.5614.0000ef3ba
Msaccess.exe10.0.6501.0Msaccess.exe10.0.6501.0000a0338
Msaccess.exe10.0.4302.0Msaccess.exe10.0.4302.0000b96aa
Msaccess.exe10.0.3409.0Msaccess.exe10.0.3409.0000a3785
Msaccess.exe10.0.2627.1Msaccess.exe10.0.2627.1000cb4f5
Msaccess.exe10.0.2616.0Msaccess.exe10.0.2616.0000be1e5
Additionally, when you create a database, you may receive the following error messages in Access:
Workgroup Administrator couldn't create the workgroup information file. Make sure you have specified a valid path and file name, that you have adequate permissions to create the file, and you have enough disk space on the destination drive. (-3100)
Microsoft Access could not find the file: File Name

CAUSE

The Jet Expression Service .dll file, Msjtes40.dll, is not correctly registered. This problem may occur if a non-Microsoft product has tried to install a copy of the Jet database engine to a custom folder and has registered that version of the Msjtes40.dll file.

RESOLUTION

To resolve this problem, you must manually register the correct version of the Msjtes40.dll file. To do this, follow these steps:
  1. Click Start, click Run, type, regsvr32.exe C:\Windows\System32\msjtes40.dll, and then click OK.
  2. When registration finishes, click OK.

MORE INFORMATION

Steps to reproduce the problem

Scenario 1

  1. Log on to the computer by using a restricted user account.
  2. Start Access.
  3. Try to create a database.

Scenario 2

  1. Log on to the computer by using an administrator user account.
  2. Start Access.
  3. Create a database.
  4. Create a table in the database by using the Table Wizard.
  5. Try to enter data into the table.
In both these scenarios, you may receive the error message that is mentioned in the "Symptoms" section.

The Windows Error Reporting dialog box appears when an error occurs that causes a program to unexpectedly close. The dialog box includes a button to send the information about the error to Microsoft. Microsoft gathers information about this kind of error in a database to try to identify the cause. For more information about the Microsoft Data Collection policy, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:8/4/2005
Keywords:kbBug kberrmsg kbinfo kbOCAbucket KB905530 kbAudEndUser kbAudITPRO