An IEEE 1394 hard disk does not work after you disconnect and then reconnect it on a Windows XP SP2-based computer (905201)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2

SYMPTOMS

Consider the following scenario. You are running a Microsoft Windows XP Service Pack 2 (SP2)-based computer. On this computer, you disconnect and then reconnect an IEEE 1394 storage device. In this scenario, you experience one of the following symptoms:
  • Disk Manager shows a new unreadable disk.
  • Disk Manager does not show the IEEE 1394 hard disk.
Note Device Manager shows no error conditions for the IEEE 1394 hard disk.

CAUSE

This issue may occur when the following conditions are true:
  • You are using a version of an IEEE 1394 Serial Bus Protocol 2 (SBP2) storage device that is not the latest version.
  • You reconnect the device to the computer immediately after you disconnect the device.
The computer does not recognize the device after a bus reset.

WORKAROUND

To work around this issue, wait for several seconds, and then reconnect the device to the computer.

MORE INFORMATION

You may experience this issue if the operating system tries to reconnect to a device too soon after a disconnection. A computer that has Windows XP SP2 installed uses a 3.5-second timer to measure the period between the moment that you reset the bus and the moment that the driver tries to reconnect to the SBP2 storage device. In this situation, certain hardware devices return an "access is denied" response to the logon command. This behavior is a hardware issue that is not caused by Windows. The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:11/11/2005
Keywords:kbtshoot kbprb KB905201 kbAudEndUser